summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb')
-rw-r--r--meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb b/meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb
new file mode 100644
index 000000000..6a09fdac4
--- /dev/null
+++ b/meta-oe/recipes-core/jpeg/libjpeg-turbo_8d+1.3.1.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression"
2HOMEPAGE = "http://libjpeg-turbo.org/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=12;md5=78fa8dbac547bb5b2a0e6457a6cfe21d \
6 file://jpeglib.h;endline=14;md5=a08bb0a80f782a9f8da313cc4015ed6f \
7 file://djpeg.c;endline=9;md5=7629c51aed78174711c20a40194a8f1b \
8"
9
10BASEPV = "${@d.getVar('PV',True).split('+')[1]}"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${BASEPV}.tar.gz"
13SRC_URI[md5sum] = "2c3a68129dac443a72815ff5bb374b05"
14SRC_URI[sha256sum] = "c132907417ddc40ed552fe53d6b91d5fecbb14a356a60ddc7ea50d6be9666fb9"
15
16S = "${WORKDIR}/${BPN}-${BASEPV}"
17
18# Drop-in replacement for jpeg
19PROVIDES = "jpeg"
20RPROVIDES_${PN} += "jpeg"
21RREPLACES_${PN} += "jpeg"
22RCONFLICTS_${PN} += "jpeg"
23
24inherit autotools pkgconfig
25
26EXTRA_OECONF = "--with-jpeg8 "
27
28PACKAGES =+ "jpeg-tools libturbojpeg"
29
30DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library."
31FILES_jpeg-tools = "${bindir}/*"
32
33FILES_libturbojpeg = "${libdir}/libturbojpeg.so"
34INSANE_SKIP_libturbojpeg = "dev-so"
35
36BBCLASSEXTEND = "native"
37DEPENDS = "nasm-native"
38
39LEAD_SONAME = "libjpeg.so.8"