summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/wvdial/wvstreams
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial/wvstreams')
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff13
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff41
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff18
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff32
4 files changed, 104 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
new file mode 100644
index 000000000..5ab633bc3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
@@ -0,0 +1,13 @@
1Index: wvstreams-4.6/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.orig/crypto/wvx509.cc 2009-07-29 11:58:16.000000000 -0400
4+++ wvstreams-4.6/crypto/wvx509.cc 2009-07-29 11:58:43.000000000 -0400
5@@ -325,7 +325,7 @@
6 }
7
8 int verify_result = X509_REQ_verify(certreq, pk);
9- if (verify_result == 0)
10+ if (verify_result == 0 || verify_result == -1)
11 {
12 debug(WvLog::Warning, "Self signed request failed");
13 X509_REQ_free(certreq);
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
new file mode 100644
index 000000000..8e4fd0329
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
@@ -0,0 +1,41 @@
1Index: wvstreams-4.6.1/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.1.orig/crypto/wvx509.cc 2011-05-20 00:02:38.119136584 +0200
4+++ wvstreams-4.6.1/crypto/wvx509.cc 2011-05-20 00:02:26.035136589 +0200
5@@ -1157,7 +1157,7 @@
6
7 if (ext)
8 {
9- X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
10+ X509V3_EXT_METHOD *method = (X509V3_EXT_METHOD *)X509V3_EXT_get(ext);
11 if (!method)
12 {
13 WvDynBuf buf;
14Index: wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc
15===================================================================
16--- wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:38.391136584 +0200
17+++ wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:35.283136585 +0200
18@@ -1,8 +1,6 @@
19 #include "wvunixdgsocket.h"
20-#ifdef MACOS
21 #include <sys/types.h>
22 #include <sys/stat.h>
23-#endif
24
25 WvUnixDGSocket::WvUnixDGSocket(WvStringParm filename, bool _server, int perms)
26 : socketfile(filename)
27Index: wvstreams-4.6.1/streams/wvatomicfile.cc
28===================================================================
29--- wvstreams-4.6.1.orig/streams/wvatomicfile.cc 2011-05-20 00:02:38.223136584 +0200
30+++ wvstreams-4.6.1/streams/wvatomicfile.cc 2011-05-20 00:02:31.619136587 +0200
31@@ -10,10 +10,7 @@
32 #include "wvatomicfile.h"
33 #include "wvfileutils.h"
34 #include "wvstrutils.h"
35-
36-#ifdef MACOS
37 #include <sys/stat.h>
38-#endif
39
40 WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
41 : tmp_file(WvString::null)
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
new file mode 100644
index 000000000..a75067a10
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
@@ -0,0 +1,18 @@
1Description: Fix FTBFS with gcc-4.7
2 Small header include change. This is borderlinde cosmetic, but still needed
3 to prevent the FTBFS.
4Author: Paul Tagliamonte <paultag@ubuntu.com>
5Origin: vendor
6Bug-Debian: http://bugs.debian.org/667418
7Last-Update: 2012-04-13
8
9--- wvstreams-4.6.1.orig/utils/wvuid.cc
10+++ wvstreams-4.6.1/utils/wvuid.cc
11@@ -33,6 +33,7 @@ wvuid_t wvgetuid()
12
13 #else // not WIN32
14
15+#include <unistd.h>
16
17 WvString wv_username_from_uid(wvuid_t uid)
18 {
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
new file mode 100644
index 000000000..ec99dcd36
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
@@ -0,0 +1,32 @@
1Index: b/gen-cc
2===================================================================
3--- a/gen-cc
4+++ b/gen-cc
5@@ -15,6 +15,11 @@
6 shift
7 shift
8
9+ echo $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
10+ -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
11+ $CPPFLAGS \\
12+ $CFLAGS \\
13+ "\$@"
14 $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
15 -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
16 $CPPFLAGS \\
17Index: b/wvrules-posix.mk
18===================================================================
19--- a/wvrules-posix.mk
20+++ b/wvrules-posix.mk
21@@ -35,11 +35,6 @@
22 # Default compiler we use for linking
23 WVLINK_CC = $(CXX)
24
25-ifneq ("$(enable_optimization)", "no")
26- CXXFLAGS+=-O2
27- CFLAGS+=-O2
28-endif
29-
30 ifneq ("$(enable_warnings)", "no")
31 CXXFLAGS+=-Wall -Woverloaded-virtual
32 CFLAGS+=-Wall