summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb')
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
new file mode 100644
index 000000000..b6b73ade5
--- /dev/null
+++ b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Apache Thrift"
2DESCRIPTION = "A software framework, for scalable cross-language services development"
3HOMEPAGE = "https://thrift.apache.org/"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e4ed21f679b2aafef26eac82ab0c2cbf"
7
8DEPENDS = "thrift-native boost python libevent flex-native bison-native \
9 glib-2.0 openssl"
10
11SRC_URI = "git://git-wip-us.apache.org/repos/asf/thrift.git;protocol=https \
12 file://0001-Forcibly-disable-check-for-Qt5.patch \
13"
14SRCREV = "61b8a29b0704ccd81b520f2300f5d1bb261fea3e"
15S = "${WORKDIR}/git"
16
17BBCLASSEXTEND = "native nativesdk"
18
19inherit pkgconfig cmake pythonnative
20
21export STAGING_INCDIR
22export STAGING_LIBDIR
23export BUILD_SYS
24export HOST_SYS
25
26EXTRA_OECMAKE = "-DWITH_QT4=OFF -DWITH_QT5=OFF"
27EXTRA_OECMAKE_class-native = "-DWITH_QT4=OFF -DWITH_QT5=OFF \
28 -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_CPP=OFF"
29EXTRA_OECMAKE_class-nativesdk = "-DWITH_QT4=OFF -DWITH_QT5=OFF \
30 -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_PYTHON=OFF"
31
32do_install_append () {
33 ln -sf thrift ${D}/${bindir}/thrift-compiler
34}
35