summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb')
-rw-r--r--meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb b/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb
new file mode 100644
index 000000000..7a72a1ed3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb
@@ -0,0 +1,45 @@
1SUMMARY = "SMS Gateway software"
2DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
3SECTION = "console/network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
6HOMEPAGE = "http://smstools3.kekekasvi.com"
7
8SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
9 file://sms_binpath_and_psops.patch"
10
11SRC_URI[md5sum] = "0241ef60e646fac1a06254a848e61ed7"
12SRC_URI[sha256sum] = "ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59"
13
14
15S = "${WORKDIR}/${PN}"
16
17RDEPENDS_${PN} = "bash"
18INITSCRIPT_NAME = "sms3"
19INITSCRIPT_PARAMS = "defaults"
20
21inherit update-rc.d
22
23do_install () {
24
25 install -d ${D}${bindir}
26 install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
27
28 install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
29 install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
30 install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
31 install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
32
33 install -d ${D}${sysconfdir}
34 install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
35
36 install -d "${D}${localstatedir}/spool"
37 install -d "${D}${localstatedir}/spool/sms"
38 install -d "${D}${localstatedir}/spool/sms/incoming"
39 install -d "${D}${localstatedir}/spool/sms/outgoing"
40 install -d "${D}${localstatedir}/spool/sms/checked"
41
42 install -d ${D}${sysconfdir}/init.d
43 install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
44
45}