summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba_4.1.12.bb')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_4.1.12.bb156
1 files changed, 156 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb b/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
new file mode 100644
index 000000000..22c2bb4fe
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba_4.1.12.bb
@@ -0,0 +1,156 @@
1SECTION = "console/network"
2
3LICENSE = "GPL-3.0+ & LGPL-3.0+ & GPL-2.0+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \
6 file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 "
7
8SAMBA_MIRROR = "http://samba.org/samba/ftp"
9MIRRORS += "\
10${SAMBA_MIRROR} http://mirror.internode.on.net/pub/samba \n \
11${SAMBA_MIRROR} http://www.mirrorservice.org/sites/ftp.samba.org \n \
12"
13
14SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
15 file://00-fix-typos-in-man-pages.patch \
16 file://01-fix-force-user-sec-ads.patch \
17 file://02-fix-ipv6-join.patch \
18 file://03-net-ads-kerberos-pac.patch \
19 file://04-ipv6-workaround.patch \
20 file://05-fix-gecos-field-with-samlogon.patch \
21 file://06-fix-nmbd-systemd-status-update.patch \
22 file://07-fix-idmap-ad-getgroups-without-gid.patch \
23 file://08-fix-idmap-ad-sfu-with-trusted-domains.patch \
24 file://09-fix-smbclient-echo-cmd-segfault.patch \
25 file://10-improve-service-principal-guessing-in-net.patch \
26 file://11-fix-overwriting-of-spns-during-net-ads-join.patch \
27 file://12-add-precreated-spns-from-AD-during-keytab-generation.patch \
28 file://13-fix-aes-enctype.patch \
29 file://14-fix-dnsupdate.patch \
30 file://15-fix-netbios-name-truncation.patch \
31 file://16-do-not-check-xsltproc-manpages.patch \
32 file://17-execute-prog-by-qemu.patch \
33 file://18-avoid-get-config-by-native-ncurses.patch \
34 file://19-systemd-daemon-is-contained-by-libsystemd.patch \
35 file://20-do-not-import-target-module-while-cross-compile.patch \
36 "
37
38SRC_URI[md5sum] = "232016d7581a1ba11e991ec2674553c4"
39SRC_URI[sha256sum] = "033604674936bf5c77d7df299b0626052b84a41505a6a6afe902f6274fc29898"
40
41inherit systemd waf-samba
42
43DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb"
44RDEPENDS_${PN} += "openldap"
45
46PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
47PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
48
49PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam"
50PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
51PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
52
53SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2"
54SAMBA4_PDB_MODULES="pdb_tdbsam,pdb_ldap,pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4"
55SAMBA4_AUTH_MODULES="auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4"
56SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODULES}"
57
58SAMBA4_LIBS="heimdal,!zlib,!popt,!talloc,!pytalloc,!pytalloc-util,!tevent,!pytevent,!tdb,!pytdb,!ldb,!pyldb"
59
60PERL_VERNDORLIB="${datadir}/perl5/vendor_perl/"
61
62EXTRA_OECONF += "--enable-fhs \
63 --with-piddir=${localstatedir}/run \
64 --with-sockets-dir=${localstatedir}/run/samba \
65 --with-modulesdir=${libdir}/samba \
66 --with-pammodulesdir=${libdir}/security \
67 --with-lockdir=${localstatedir}/lib/samba \
68 --with-cachedir=${localstatedir}/lib/samba \
69 --with-perl-lib-install-dir=${PERL_VERNDORLIB} \
70 --disable-gnutls \
71 --disable-rpath-install \
72 --with-shared-modules=${SAMBA4_MODULES} \
73 --bundled-libraries=${SAMBA4_LIBS} \
74 --with-system-mitkrb5 \
75 --without-ad-dc \
76 ${@base_conditional('TARGET_ARCH', 'x86_64', '', '--disable-glusterfs', d)} \
77 --with-cluster-support \
78 --enable-old-ctdb \
79 --with-profiling-data \
80 --with-libiconv=${STAGING_DIR_HOST}${prefix} \
81 "
82
83LDFLAGS += "-Wl,-z,relro,-z,now"
84
85do_install_append() {
86 rmdir --ignore-fail-on-non-empty "${D}/${localstatedir}/run"
87
88 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
89 install -d ${D}${systemd_unitdir}/system
90 for i in nmb smb winbind; do
91 install -m 0644 packaging/systemd/$i.service ${D}${systemd_unitdir}/system
92 done
93 sed -e 's,@BASE_BINDIR@,${base_bindir},g' \
94 -e 's,@SBINDIR@,${sbindir},g' \
95 -i ${D}${systemd_unitdir}/system/*.service
96
97 install -d ${D}${sysconfdir}/tmpfiles.d
98 echo "d ${localstatedir}/log/samba 0755 root root -" \
99 > ${D}${sysconfdir}/tmpfiles.d/99-${BPN}.conf
100 fi
101
102 install -d ${D}${sysconfdir}/samba
103 echo "127.0.0.1 localhost" > ${D}${sysconfdir}/samba/lmhosts
104 install -m644 packaging/LSB/smb.conf ${D}${sysconfdir}/samba/smb.conf
105
106 install -d ${D}${libdir}/tmpfiles.d
107 install -m644 packaging/systemd/samba.conf.tmp ${D}${libdir}/tmpfiles.d/samba.conf
108
109 install -d ${D}${sysconfdir}/sysconfig/
110 install -m644 packaging/systemd/samba.sysconfig ${D}${sysconfdir}/sysconfig/samba
111}
112
113PACKAGES += "${PN}-python ${PN}-python-dbg ${PN}-pidl libwinbind libwinbind-dbg libwinbind-krb5-locator"
114
115FILES_${PN} += "/run \
116 ${libdir}/security/pam_smbpass.so \
117 ${libdir}/tmpfiles.d/* \
118 "
119
120SMB_SERVICE="${systemd_unitdir}/system/nmb.service ${systemd_unitdir}/system/smb.service"
121FILES_${PN} +="${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${SMB_SERVICE}', '', d)}"
122
123FILES_${PN}-dbg += "${libdir}/samba/idmap/.debug/* \
124 ${libdir}/samba/pdb/.debug/* \
125 ${libdir}/samba/auth/.debug/* \
126 ${libdir}/samba/nss_info/.debug/* \
127 ${libdir}/samba/ldb/.debug/* \
128 ${libdir}/samba/vfs/.debug/* \
129 ${libdir}/security/.debug/pam_smbpass.so \
130 "
131
132FILES_libwinbind = "${libdir}/security/pam_winbind.so"
133FILES_libwinbind += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/winbind.service', '', d)}"
134FILES_libwinbind-dbg = "${libdir}/security/.debug/pam_winbind.so"
135FILES_libwinbind-krb5-locator = "${libdir}/winbind_krb5_locator.so"
136
137FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*.so \
138 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/*.py \
139 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/*.so \
140 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/dcerpc/*.so \
141 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/dcerpc/*.py \
142 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/external/* \
143 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/netcmd/*.py \
144 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/provision/*.py \
145 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/samba3/*.py \
146 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/samba3/*.so \
147 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/tests/* \
148 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/web_server/* \
149 "
150FILES_${PN}-python-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug/* \
151 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/.debug/* \
152 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/samba3/.debug/* \
153 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/samba/dcerpc/.debug/* \
154 "
155
156FILES_${PN}-pidl = "${datadir}/perl5/vendor_perl/*"