summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb')
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb b/meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb
new file mode 100644
index 000000000..8483293b9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/openssl/openssl-native_1.0.0c.bb
@@ -0,0 +1,27 @@
1require openssl.inc
2
3inherit pkgconfig native
4
5SRC_URI[src.md5sum] = "ff8fb85610aef328315a9decbb2712e4"
6SRC_URI[src.sha256sum] = "f731b36de3edaa361179ae6f449668b248a360e34e31e92902d976e9b9d604eb"
7PR = "${INC_PR}.0"
8
9DEFAULT_PREFERENCE = "-1"
10
11export DIRS = "crypto ssl apps engines"
12
13# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
14export FULL_OPTIMIZATION = " "
15export BUILD_OPTIMIZATION = " "
16
17SRC_URI += "file://configure-targets.patch \
18 file://shared-libs.patch \
19 file://debian.patch \
20 file://libdeps-first.patch \
21 "
22
23PARALLEL_MAKE = ""
24
25CFLAG += " -Wa,--noexecstack "
26
27NATIVE_INSTALL_WORKS = "1"