summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch')
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch546
1 files changed, 546 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch
new file mode 100644
index 000000000..60e338816
--- /dev/null
+++ b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/debian.patch
@@ -0,0 +1,546 @@
1Index: openssl-0.9.8m/Makefile
2===================================================================
3--- openssl-0.9.8m.orig/Makefile 2010-02-26 01:21:14.000000000 +0800
4+++ openssl-0.9.8m/Makefile 2010-03-09 20:17:26.515664333 +0800
5@@ -26,10 +26,10 @@
6 # for, say, /usr/ and yet have everything installed to /tmp/somedir/usr/.
7 # Normally it is left empty.
8 INSTALL_PREFIX=
9-INSTALLTOP=/usr/local/ssl
10+INSTALLTOP=/usr
11
12 # Do not edit this manually. Use Configure --openssldir=DIR do change this!
13-OPENSSLDIR=/usr/local/ssl
14+OPENSSLDIR=/usr/lib/ssl
15
16 # NO_IDEA - Define to build without the IDEA algorithm
17 # NO_RC4 - Define to build without the RC4 algorithm
18@@ -155,10 +155,11 @@
19
20 MAKEFILE= Makefile
21
22-MANDIR=$(OPENSSLDIR)/man
23+MANDIR=/usr/share/man
24 MAN1=1
25 MAN3=3
26-MANSUFFIX=
27+MANSUFFIX=ssl
28+MANSECTION=SSL
29 SHELL=/bin/sh
30
31 TOP= .
32@@ -170,8 +171,8 @@
33 SHARED_SSL=libssl$(SHLIB_EXT)
34 SHARED_FIPS=
35 SHARED_LIBS=
36-SHARED_LIBS_LINK_EXTS=
37-SHARED_LDFLAGS=
38+SHARED_LIBS_LINK_EXTS=.so
39+SHARED_LDFLAGS=-m64 -Wl,--version-script=openssl.ld
40
41 GENERAL= Makefile
42 BASENAME= openssl
43@@ -447,7 +448,8 @@
44 echo 'Description: OpenSSL cryptography library'; \
45 echo 'Version: '$(VERSION); \
46 echo 'Requires: '; \
47- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
48+ echo 'Libs: -L$${libdir} -lcrypto'; \
49+ echo 'Libs.private: $(EX_LIBS)'; \
50 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
51
52 libssl.pc: Makefile
53@@ -460,7 +462,8 @@
54 echo 'Description: Secure Sockets Layer and cryptography libraries'; \
55 echo 'Version: '$(VERSION); \
56 echo 'Requires: '; \
57- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
58+ echo 'Libs: -L$${libdir} -lssl'; \
59+ echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
60 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
61
62 openssl.pc: Makefile
63@@ -473,7 +476,8 @@
64 echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
65 echo 'Version: '$(VERSION); \
66 echo 'Requires: '; \
67- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
68+ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
69+ echo 'Libs.private: $(EX_LIBS)'; \
70 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
71
72 Makefile: Makefile.org Configure config
73@@ -622,7 +626,7 @@
74 install_sw:
75 @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
76 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
77- $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
78+ $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines \
79 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/pkgconfig \
80 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl \
81 $(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
82@@ -700,7 +704,7 @@
83 echo "installing man$$sec/$$fn.$${sec}$(MANSUFFIX)"; \
84 (cd `$(PERL) util/dirname.pl $$i`; \
85 sh -c "$$pod2man \
86- --section=$$sec --center=OpenSSL \
87+ --section=$${sec}$(MANSECTION) --center=OpenSSL \
88 --release=$(VERSION) `basename $$i`") \
89 > $(INSTALL_PREFIX)$(MANDIR)/man$$sec/$$fn.$${sec}$(MANSUFFIX); \
90 $(PERL) util/extract-names.pl < $$i | \
91@@ -717,7 +721,7 @@
92 echo "installing man$$sec/$$fn.$${sec}$(MANSUFFIX)"; \
93 (cd `$(PERL) util/dirname.pl $$i`; \
94 sh -c "$$pod2man \
95- --section=$$sec --center=OpenSSL \
96+ --section=$${sec}$(MANSECTION) --center=OpenSSL \
97 --release=$(VERSION) `basename $$i`") \
98 > $(INSTALL_PREFIX)$(MANDIR)/man$$sec/$$fn.$${sec}$(MANSUFFIX); \
99 $(PERL) util/extract-names.pl < $$i | \
100Index: openssl-0.9.8m/Configure
101===================================================================
102--- openssl-0.9.8m.orig/Configure 2010-03-09 16:15:42.000000000 +0800
103+++ openssl-0.9.8m/Configure 2010-03-09 20:18:16.566914027 +0800
104@@ -1,4 +1,4 @@
105-:
106+#!/usr/local/bin/perl
107 eval 'exec perl -S $0 ${1+"$@"}'
108 if $running_under_some_shell;
109 ##
110@@ -326,6 +326,47 @@
111 "osf1-alpha-cc", "cc:-std1 -tune host -O4 -readonly_strings::(unknown):::SIXTY_FOUR_BIT_LONG RC4_CHUNK:${no_asm}:dlfcn:alpha-osf1-shared:::.so",
112 "tru64-alpha-cc", "cc:-std1 -tune host -fast -readonly_strings::-pthread:::SIXTY_FOUR_BIT_LONG RC4_CHUNK:${no_asm}:dlfcn:alpha-osf1-shared::-msym:.so",
113
114+# Debian GNU/* (various architectures)
115+"debian-alpha","gcc:-DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_RISC1 DES_UNROLL:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
116+"debian-alpha-ev4","gcc:-DTERMIO -O3 -Wa,--noexecstack -mcpu=ev4 -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_RISC1 DES_UNROLL:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
117+"debian-alpha-ev5","gcc:-DTERMIO -O3 -Wa,--noexecstack -mcpu=ev5 -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_RISC1 DES_UNROLL:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
118+"debian-arm","gcc:-DL_ENDIAN -DTERMIO -O2 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
119+"debian-armeb","gcc:-DB_ENDIAN -DTERMIO -O2 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
120+"debian-armel","gcc:-DL_ENDIAN -DTERMIO -O2 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
121+#"debian-amd64","gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
122+"debian-amd64", "gcc:-m64 -DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall -DMD32_REG_T=int::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK RC4_CHAR BF_PTR2 DES_INT DES_UNROLL:${x86_64_asm}:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
123+"debian-kfreebsd-amd64","gcc:-m64 -DL_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -Wall -DMD32_REG_T=int::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK BF_PTR2 DES_INT DES_UNROLL:${x86_64_asm}:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
124+#"debian-freebsd-alpha","gcc:-DTERMIOS -O -Wa,--noexecstack -fomit-frame-pointer::(unknown):::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
125+"debian-kfreebsd-i386","gcc:-DL_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -m486 -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
126+"debian-hppa","gcc:-DB_ENDIAN -DTERMIO -O2 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG MD2_CHAR RC4_INDEX::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
127+"debian-hurd-i386","gcc:-DL_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -m486 -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
128+"debian-ia64","gcc:-DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK RC4_CHAR:${ia64_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
129+#"debian-i386","gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -fomit-frame-pointer -m486 -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::dlfcn:linux-shared:-fPIC",
130+"debian-i386","gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
131+"debian-i386-i486","gcc:-DL_ENDIAN -DTERMIO -O3 -march=i486 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
132+"debian-i386-i586","gcc:-DL_ENDIAN -DTERMIO -O3 -march=i586 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
133+"debian-i386-i686/cmov","gcc:-DL_ENDIAN -DTERMIO -O3 -march=i686 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
134+"debian-m68k","gcc:-DB_ENDIAN -DTERMIO -O2 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG MD2_CHAR RC4_INDEX::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
135+"debian-mips", "gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
136+"debian-mipsel", "gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
137+"debian-netbsd-i386", "gcc:-DL_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -m486 -Wall::(unknown):::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
138+"debian-netbsd-m68k", "gcc:-DB_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -Wall::(unknown):::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
139+"debian-netbsd-sparc", "gcc:-DB_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -mv8 -Wall::(unknown):::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
140+"debian-openbsd-alpha","gcc:-DTERMIOS -O3 -Wa,--noexecstack -g::(unknown):::SIXTY_FOUR_BIT_LONG DES_INT DES_PTR DES_RISC2::::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
141+"debian-openbsd-i386", "gcc:-DL_ENDIAN -DTERMIOS -O3 -Wa,--noexecstack -g -m486::(unknown):::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
142+"debian-openbsd-mips","gcc:-O2 -Wa,--noexecstack -g -DL_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX RC4_CHAR DES_UNROLL DES_RISC2 DES_PTR BF_PTR:::::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
143+"debian-powerpc","gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_UNROLL DES_RISC2 DES_PTR MD2_CHAR RC4_INDEX::linux_ppc32.o::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
144+"debian-ppc64","gcc:-m64 -DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL::linux_ppc64.o::::::::::dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
145+"debian-s390","gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
146+"debian-sh3", "gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
147+"debian-sh4", "gcc:-DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
148+"debian-sh3eb", "gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
149+"debian-sh4eb", "gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
150+"debian-m32r","gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
151+"debian-sparc","gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_UNROLL BF_PTR::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
152+"debian-sparc-v8","gcc:-DB_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -mcpu=v8 -g -Wall -DBN_DIV2W::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_UNROLL BF_PTR::sparcv8.o:des_enc-sparc.o fcrypt_b.o:::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
153+"debian-sparc-v9","gcc:-DB_ENDIAN -DTERMIO -O3 -mcpu=v9 -Wa,--noexecstack -Wa,-Av8plus -g -Wall -DULTRASPARC -DBN_DIV2W::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_UNROLL BF_PTR::sparcv8plus.o:des_enc-sparc.o fcrypt_b.o:::md5-sparcv8plus.o::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
154+
155 ####
156 #### Variety of LINUX:-)
157 ####
158@@ -505,7 +546,7 @@
159 # Cygwin
160 "Cygwin-pre1.3", "gcc:-DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::(unknown):CYGWIN32::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${no_asm}:win32",
161 "Cygwin", "gcc:-DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -march=i486 -Wall:::CYGWIN32::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_coff_asm}:dlfcn:cygwin-shared:-D_WINDLL:-shared:.dll.a",
162-"debug-Cygwin", "gcc:-DTERMIOS -DL_ENDIAN -march=i486 -Wall -DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -DOPENSSL_NO_ASM -g -Wformat -Wshadow -Wmissing-prototypes -Wmissing-declarations -Werror:::CYGWIN32:::${no_asm}:dlfcn:cygwin-shared:-D_WINDLL:-shared:.dll.a",
163+-"debug-Cygwin", "gcc:-DTERMIOS -DL_ENDIAN -march=i486 -Wall -DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -DOPENSSL_NO_ASM -g -Wformat -Wshadow -Wmissing-prototypes -Wmissing-declarations -Werror:::CYGWIN32:::${no_asm}:dlfcn:cygwin-shared:-D_WINDLL:-shared:.dll.a",
164
165 # NetWare from David Ward (dsward@novell.com)
166 # requires either MetroWerks NLM development tools, or gcc / nlmconv
167@@ -1477,6 +1518,8 @@
168 }
169 }
170
171+$shared_ldflag .= " -Wl,--version-script=openssl.ld";
172+
173 open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n";
174 unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new";
175 open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n";
176@@ -1576,7 +1619,8 @@
177 elsif ($shared_extension ne "" && $shared_extension =~ /^\.s([ol])\.[^\.]*\.[^\.]*$/)
178 {
179 my $sotmp = $1;
180- s/^SHARED_LIBS_LINK_EXTS=.*/SHARED_LIBS_LINK_EXTS=.s$sotmp.\$(SHLIB_MAJOR) .s$sotmp/;
181+# s/^SHARED_LIBS_LINK_EXTS=.*/SHARED_LIBS_LINK_EXTS=.s$sotmp.\$(SHLIB_MAJOR) .s$sotmp/;
182+ s/^SHARED_LIBS_LINK_EXTS=.*/SHARED_LIBS_LINK_EXTS=.s$sotmp/;
183 }
184 elsif ($shared_extension ne "" && $shared_extension =~ /^\.[^\.]*\.[^\.]*\.dylib$/)
185 {
186@@ -1706,7 +1750,7 @@
187 # $foo is to become "$prefix/lib$multilib/engines";
188 # as Makefile.org and engines/Makefile are adapted for
189 # $multilib suffix.
190- my $foo = "$prefix/lib/engines";
191+ my $foo = "$prefix/lib/ssl/engines";
192 $foo =~ s/\\/\\\\/g;
193 print OUT "#define ENGINESDIR \"$foo\"\n";
194 }
195Index: openssl-0.9.8m/config
196===================================================================
197--- openssl-0.9.8m.orig/config 2009-10-15 20:58:00.000000000 +0800
198+++ openssl-0.9.8m/config 2010-03-09 20:16:50.506902007 +0800
199@@ -162,8 +162,8 @@
200 echo "${MACHINE}-whatever-linux1"; exit 0
201 ;;
202
203- GNU*)
204- echo "hurd-x86"; exit 0;
205+ GNU:*|GNU/*:*)
206+ echo "${MACHINE}-gnuish"; exit 0;
207 ;;
208
209 LynxOS:*)
210Index: openssl-0.9.8m/Makefile.org
211===================================================================
212--- openssl-0.9.8m.orig/Makefile.org 2010-03-09 16:15:42.000000000 +0800
213+++ openssl-0.9.8m/Makefile.org 2010-03-09 20:18:44.095663922 +0800
214@@ -153,10 +153,11 @@
215
216 MAKEFILE= Makefile
217
218-MANDIR=$(OPENSSLDIR)/man
219+MANDIR=/usr/share/man
220 MAN1=1
221 MAN3=3
222-MANSUFFIX=
223+MANSUFFIX=ssl
224+MANSECTION=SSL
225 SHELL=/bin/sh
226
227 TOP= .
228@@ -445,7 +446,8 @@
229 echo 'Description: OpenSSL cryptography library'; \
230 echo 'Version: '$(VERSION); \
231 echo 'Requires: '; \
232- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
233+ echo 'Libs: -L$${libdir} -lcrypto'; \
234+ echo 'Libs.private: $(EX_LIBS)'; \
235 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
236
237 libssl.pc: Makefile
238@@ -458,7 +460,8 @@
239 echo 'Description: Secure Sockets Layer and cryptography libraries'; \
240 echo 'Version: '$(VERSION); \
241 echo 'Requires: '; \
242- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
243+ echo 'Libs: -L$${libdir} -lssl'; \
244+ echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
245 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
246
247 openssl.pc: Makefile
248@@ -471,7 +474,8 @@
249 echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
250 echo 'Version: '$(VERSION); \
251 echo 'Requires: '; \
252- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
253+ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
254+ echo 'Libs.private: $(EX_LIBS)'; \
255 echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
256
257 Makefile: Makefile.org Configure config
258@@ -620,7 +624,7 @@
259 install_sw:
260 @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
261 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
262- $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
263+ $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines \
264 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/pkgconfig \
265 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl \
266 $(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
267@@ -698,7 +702,7 @@
268 echo "installing man$$sec/$$fn.$${sec}$(MANSUFFIX)"; \
269 (cd `$(PERL) util/dirname.pl $$i`; \
270 sh -c "$$pod2man \
271- --section=$$sec --center=OpenSSL \
272+ --section=$${sec}$(MANSECTION) --center=OpenSSL \
273 --release=$(VERSION) `basename $$i`") \
274 > $(INSTALL_PREFIX)$(MANDIR)/man$$sec/$$fn.$${sec}$(MANSUFFIX); \
275 $(PERL) util/extract-names.pl < $$i | \
276@@ -715,7 +719,7 @@
277 echo "installing man$$sec/$$fn.$${sec}$(MANSUFFIX)"; \
278 (cd `$(PERL) util/dirname.pl $$i`; \
279 sh -c "$$pod2man \
280- --section=$$sec --center=OpenSSL \
281+ --section=$${sec}$(MANSECTION) --center=OpenSSL \
282 --release=$(VERSION) `basename $$i`") \
283 > $(INSTALL_PREFIX)$(MANDIR)/man$$sec/$$fn.$${sec}$(MANSUFFIX); \
284 $(PERL) util/extract-names.pl < $$i | \
285Index: openssl-0.9.8m/openssl.ld
286===================================================================
287--- /dev/null 1970-01-01 00:00:00.000000000 +0000
288+++ openssl-0.9.8m/openssl.ld 2010-03-09 20:16:50.506902007 +0800
289@@ -0,0 +1,5 @@
290+OPENSSL_0.9.8 {
291+ global:
292+ *;
293+};
294+
295Index: openssl-0.9.8m/apps/s_time.c
296===================================================================
297--- openssl-0.9.8m.orig/apps/s_time.c 2003-12-27 22:40:17.000000000 +0800
298+++ openssl-0.9.8m/apps/s_time.c 2010-03-09 20:16:50.516901237 +0800
299@@ -117,6 +117,7 @@
300
301 /* The following if from times(3) man page. It may need to be changed
302 */
303+#undef HZ
304 #ifndef HZ
305 # ifdef _SC_CLK_TCK
306 # define HZ ((double)sysconf(_SC_CLK_TCK))
307Index: openssl-0.9.8m/engines/openssl.ld
308===================================================================
309--- /dev/null 1970-01-01 00:00:00.000000000 +0000
310+++ openssl-0.9.8m/engines/openssl.ld 2010-03-09 20:16:50.516901237 +0800
311@@ -0,0 +1,5 @@
312+OPENSSL_0.9.8 {
313+ global:
314+ *;
315+};
316+
317Index: openssl-0.9.8m/doc/Makefile
318===================================================================
319--- /dev/null 1970-01-01 00:00:00.000000000 +0000
320+++ openssl-0.9.8m/doc/Makefile 2010-03-09 20:16:50.516901237 +0800
321@@ -0,0 +1,40 @@
322+VERSION =
323+
324+#PODS = $(wildcard *.pod)
325+#MANS = $(addsuffix .man, $(basename $(PODS)))
326+
327+MANS = openssl.1 ssl.3 crypto.3
328+
329+P2M = pod2man --center='OpenSSL Documentation' --release="OpenSSL $(VERSION)"
330+
331+all: manpages
332+
333+.PHONY: manpages
334+
335+manpages: openssl.1 crypto.3 ssl.3
336+
337+openssl.1:
338+ $(P2M) --section=1 openssl.pod > openssl.1
339+
340+crypto.3:
341+ $(P2M) --section=3 crypto.pod > crypto.3
342+
343+ssl.3:
344+ $(P2M) --section=3 ssl.pod > ssl.3
345+
346+.PHONY: install
347+install:
348+ mkdir -p $(INSTALL_PREFIX)$(INSTALLTOP)/share/man/man1
349+ mkdir -p $(INSTALL_PREFIX)$(INSTALLTOP)/share/man/man3
350+ install -m 644 -p openssl.1 $(INSTALL_PREFIX)$(INSTALLTOP)/share/man/man1
351+ install -m 644 -p crypto.3 $(INSTALL_PREFIX)$(INSTALLTOP)/share/man/man3
352+ install -m 644 -p ssl.3 $(INSTALL_PREFIX)$(INSTALLTOP)/share/man/man3
353+ rm -f $(MANS)
354+
355+.PHONY: clean
356+clean:
357+ rm -f $(MANS)
358+
359+.PHONY: realclean
360+realclean:
361+ -$(MAKE) clean
362Index: openssl-0.9.8m/doc/apps/c_rehash.pod
363===================================================================
364--- /dev/null 1970-01-01 00:00:00.000000000 +0000
365+++ openssl-0.9.8m/doc/apps/c_rehash.pod 2010-03-09 20:16:50.516901237 +0800
366@@ -0,0 +1,55 @@
367+
368+=pod
369+
370+=head1 NAME
371+
372+c_rehash - Create symbolic links to files named by the hash values
373+
374+=head1 SYNOPSIS
375+
376+B<c_rehash>
377+[directory] ...
378+
379+=head1 DESCRIPTION
380+
381+c_rehash scans directories and takes a hash value of each .pem and .crt file in the directory. It then creates symbolic links for each of the files named by the hash value. This is useful as many programs require directories to be set up like this in order to find the certificates they require.
382+
383+If any directories are named on the command line then these directories are processed in turn. If not then and the environment variable SSL_CERT_DIR is defined then that is consulted. This variable should be a colon (:) separated list of directories, all of which will be processed. If neither of these conditions are true then /usr/lib/ssl/certs is processed.
384+
385+For each directory that is to be processed he user must have write permissions on the directory, if they do not then nothing will be printed for that directory.
386+
387+Note that this program deletes all the symbolic links that look like ones that it creates before processing a directory. Beware that if you run the program on a directory that contains symbolic links for other purposes that are named in the same format as those created by this program they will be lost.
388+
389+The hashes for certificate files are of the form <hash>.<n> where n is an integer. If the hash value already exists then n will be incremented, unless the file is a duplicate. Duplicates are detected using the fingerprint of the certificate. A warning will be printed if a duplicate is detected. The hashes for CRL files are of the form <hash>.r<n> and have the same behavior.
390+
391+The program will also warn if there are files with extension .pem which are not certificate or CRL files.
392+
393+The program uses the openssl program to compute the hashes and fingerprints. It expects the executable to be named openssl and be on the PATH, or in the /usr/lib/ssl/bin directory. If the OPENSSL environment variable is defined then this is used instead as the executable that provides the hashes and fingerprints. When called as $OPENSSL x509 -hash -fingerprint -noout -in $file it must output the hash of $file on the first line followed by the fingerprint on the second line, optionally prefixed with some text and an equals sign (=).
394+
395+=head1 OPTIONS
396+
397+None
398+
399+=head1 ENVIRONMENT
400+
401+=over 4
402+
403+=item B<OPENSSL>
404+
405+The name (and path) of an executable to use to generate hashes and fingerprints (see above).
406+
407+=item B<SSL_CERT_DIR>
408+
409+Colon separated list of directories to operate on. Ignored if directories are listed on the command line.
410+
411+=head1 SEE ALSO
412+
413+L<openssl(1)|openssl(1)>, L<x509(1)|x509(1)>
414+
415+=back
416+
417+=head1 BUGS
418+
419+No known bugs
420+
421+=cut
422Index: openssl-0.9.8m/crypto/Makefile
423===================================================================
424--- openssl-0.9.8m.orig/crypto/Makefile 2010-03-09 16:15:42.000000000 +0800
425+++ openssl-0.9.8m/crypto/Makefile 2010-03-09 20:16:50.516901237 +0800
426@@ -57,7 +57,7 @@
427 echo " #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
428 echo '#endif' ) >buildinf.h
429
430-x86cpuid-elf.s: x86cpuid.pl perlasm/x86asm.pl
431+x86cpuid-elf.S: x86cpuid.pl perlasm/x86asm.pl
432 $(PERL) x86cpuid.pl elf $(CFLAGS) $(PROCESSOR) > $@
433 x86cpuid-cof.s: x86cpuid.pl perlasm/x86asm.pl
434 $(PERL) x86cpuid.pl coff $(CFLAGS) $(PROCESSOR) > $@
435@@ -70,7 +70,7 @@
436 uplink-cof.s: ../ms/uplink.pl
437 $(PERL) ../ms/uplink.pl coff > $@
438
439-x86_64cpuid.s: x86_64cpuid.pl
440+x86_64cpuid.S: x86_64cpuid.pl
441 $(PERL) x86_64cpuid.pl $@
442 ia64cpuid.s: ia64cpuid.S
443 $(CC) $(CFLAGS) -E ia64cpuid.S > $@
444Index: openssl-0.9.8m/crypto/opensslconf.h
445===================================================================
446--- openssl-0.9.8m.orig/crypto/opensslconf.h 2010-02-26 01:21:14.000000000 +0800
447+++ openssl-0.9.8m/crypto/opensslconf.h 2010-03-09 20:16:50.516901237 +0800
448@@ -20,6 +20,9 @@
449 #ifndef OPENSSL_NO_JPAKE
450 # define OPENSSL_NO_JPAKE
451 #endif
452+#ifndef OPENSSL_NO_IDEA
453+# define OPENSSL_NO_IDEA
454+#endif
455 #ifndef OPENSSL_NO_KRB5
456 # define OPENSSL_NO_KRB5
457 #endif
458@@ -62,6 +65,9 @@
459 # if defined(OPENSSL_NO_JPAKE) && !defined(NO_JPAKE)
460 # define NO_JPAKE
461 # endif
462+# if defined(OPENSSL_NO_IDEA) && !defined(NO_IDEA)
463+# define NO_IDEA
464+# endif
465 # if defined(OPENSSL_NO_KRB5) && !defined(NO_KRB5)
466 # define NO_KRB5
467 # endif
468@@ -101,8 +107,8 @@
469
470 #if !(defined(VMS) || defined(__VMS)) /* VMS uses logical names instead */
471 #if defined(HEADER_CRYPTLIB_H) && !defined(OPENSSLDIR)
472-#define ENGINESDIR "/usr/local/ssl/lib/engines"
473-#define OPENSSLDIR "/usr/local/ssl"
474+#define ENGINESDIR "/usr/lib/ssl/engines"
475+#define OPENSSLDIR "/usr/lib/ssl"
476 #endif
477 #endif
478
479@@ -133,14 +139,14 @@
480 * - Intel P6 because partial register stalls are very expensive;
481 * - elder Alpha because it lacks byte load/store instructions;
482 */
483-#define RC4_INT unsigned int
484+#define RC4_INT unsigned char
485 #endif
486 #if !defined(RC4_CHUNK)
487 /*
488 * This enables code handling data aligned at natural CPU word
489 * boundary. See crypto/rc4/rc4_enc.c for further details.
490 */
491-#undef RC4_CHUNK
492+#define RC4_CHUNK unsigned long
493 #endif
494 #endif
495
496@@ -148,7 +154,7 @@
497 /* If this is set to 'unsigned int' on a DEC Alpha, this gives about a
498 * %20 speed up (longs are 8 bytes, int's are 4). */
499 #ifndef DES_LONG
500-#define DES_LONG unsigned long
501+#define DES_LONG unsigned int
502 #endif
503 #endif
504
505@@ -162,9 +168,9 @@
506 /* The prime number generation stuff may not work when
507 * EIGHT_BIT but I don't care since I've only used this mode
508 * for debuging the bignum libraries */
509-#undef SIXTY_FOUR_BIT_LONG
510+#define SIXTY_FOUR_BIT_LONG
511 #undef SIXTY_FOUR_BIT
512-#define THIRTY_TWO_BIT
513+#undef THIRTY_TWO_BIT
514 #undef SIXTEEN_BIT
515 #undef EIGHT_BIT
516 #endif
517@@ -178,7 +184,7 @@
518
519 #if defined(HEADER_BF_LOCL_H) && !defined(CONFIG_HEADER_BF_LOCL_H)
520 #define CONFIG_HEADER_BF_LOCL_H
521-#undef BF_PTR
522+#define BF_PTR2
523 #endif /* HEADER_BF_LOCL_H */
524
525 #if defined(HEADER_DES_LOCL_H) && !defined(CONFIG_HEADER_DES_LOCL_H)
526@@ -208,7 +214,7 @@
527 /* Unroll the inner loop, this sometimes helps, sometimes hinders.
528 * Very mucy CPU dependant */
529 #ifndef DES_UNROLL
530-#undef DES_UNROLL
531+#define DES_UNROLL
532 #endif
533
534 /* These default values were supplied by
535Index: openssl-0.9.8m/crypto/sha/sha.h
536===================================================================
537--- openssl-0.9.8m.orig/crypto/sha/sha.h 2008-09-16 18:47:28.000000000 +0800
538+++ openssl-0.9.8m/crypto/sha/sha.h 2010-03-09 20:16:50.516901237 +0800
539@@ -59,6 +59,7 @@
540 #ifndef HEADER_SHA_H
541 #define HEADER_SHA_H
542
543+#include <stddef.h>
544 #include <openssl/e_os2.h>
545 #include <stddef.h>
546