diff options
Diffstat (limited to 'meta-oe/recipes-connectivity/libwebsockets')
-rw-r--r-- | meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb (renamed from meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb) | 5 |
2 files changed, 2 insertions, 35 deletions
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch deleted file mode 100644 index 41d004d9ff..0000000000 --- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 722e44cb5b74cae206f47a6dc0d985eba8ed1b2e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 26 Jan 2023 17:17:49 -0800 | ||
4 | Subject: [PATCH] Fix -Werror=enum-int-mismatch in | ||
5 | lws_tls_server_abort_connection() | ||
6 | |||
7 | GCC 13 is findinf this function signature mismatch. | ||
8 | |||
9 | ../git/lib/tls/openssl/openssl-server.c:713:1: error: conflicting types for 'lws_tls_server_abort_connection' due to enum/integer mismatch; have 'int(struct lws *)' [-Werror=enum-int-mismatch] | ||
10 | |||
11 | Upstream-Status: Submitted [https://github.com/warmcat/libwebsockets/pull/2824] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | lib/tls/openssl/openssl-server.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/lib/tls/openssl/openssl-server.c b/lib/tls/openssl/openssl-server.c | ||
18 | index f2e77324f..43d65e030 100644 | ||
19 | --- a/lib/tls/openssl/openssl-server.c | ||
20 | +++ b/lib/tls/openssl/openssl-server.c | ||
21 | @@ -699,7 +699,7 @@ lws_tls_server_new_nonblocking(struct lws *wsi, lws_sockfd_type accept_fd) | ||
22 | return 0; | ||
23 | } | ||
24 | |||
25 | -int | ||
26 | +enum lws_ssl_capable_status | ||
27 | lws_tls_server_abort_connection(struct lws *wsi) | ||
28 | { | ||
29 | if (wsi->tls.use_ssl) | ||
30 | -- | ||
31 | 2.39.1 | ||
32 | |||
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb index 95c2854fa6..4518e2faaa 100644 --- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb +++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb | |||
@@ -7,9 +7,8 @@ DEPENDS = "zlib" | |||
7 | DEPENDS:append:class-native = " libcap-native" | 7 | DEPENDS:append:class-native = " libcap-native" |
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |
10 | SRCREV = "b0a749c8e7a8294b68581ce4feac0e55045eb00b" | 10 | SRCREV = "4415e84c095857629863804e941b9e1c2e9347ef" |
11 | SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable \ | 11 | SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable" |
12 | file://0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch" | ||
13 | 12 | ||
14 | UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases" | 13 | UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases" |
15 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" | 14 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |