summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb')
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb
new file mode 100644
index 000000000..e2d0594bd
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.13.6.bb
@@ -0,0 +1,103 @@
1SUMMARY = "A network authentication protocol"
2DESCRIPTION = "Kerberos is a system for authenticating users and services on a network. \
3 Kerberos is a trusted third-party service. That means that there is a \
4 third party (the Kerberos server) that is trusted by all the entities on \
5 the network (users and services, usually called "principals"). \
6 . \
7 This is the MIT reference implementation of Kerberos V5. \
8 . \
9 This package contains the Kerberos key server (KDC). The KDC manages all \
10 authentication credentials for a Kerberos realm, holds the master keys \
11 for the realm, and responds to authentication requests. This package \
12 should be installed on both master and slave KDCs."
13
14HOMEPAGE = "http://web.mit.edu/Kerberos/"
15SECTION = "console/network"
16LICENSE = "MIT"
17LIC_FILES_CHKSUM = "file://${S}/../NOTICE;md5=c6f37efad53b098e420f45e7ab6807dc"
18DEPENDS = "ncurses util-linux e2fsprogs e2fsprogs-native"
19
20inherit autotools-brokensep binconfig perlnative systemd
21
22SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
23SRC_URI = "http://web.mit.edu/kerberos/dist/${BPN}/${SHRT_VER}/${BP}.tar.gz \
24 file://0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch \
25 file://debian-suppress-usr-lib-in-krb5-config.patch;striplevel=2 \
26 file://crosscompile_nm.patch \
27 file://etc/init.d/krb5-kdc \
28 file://etc/init.d/krb5-admin-server \
29 file://etc/default/krb5-kdc \
30 file://etc/default/krb5-admin-server \
31 file://krb5-kdc.service \
32 file://krb5-admin-server.service \
33"
34SRC_URI[md5sum] = "6164ca9c075b4ecc68eadd6d13040417"
35SRC_URI[sha256sum] = "9c0a46b8918237a53916370d2e02298c2b294f55f0351f9404e18930bc26badc"
36
37S = "${WORKDIR}/${BP}/src"
38
39SYSTEMD_SERVICE_${PN} = "krb5-admin-server.service krb5-kdc.service"
40SYSTEMD_AUTO_ENABLE = "disable"
41
42PACKAGECONFIG ??= "openssl"
43PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
44PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl"
45PACKAGECONFIG[keyutils] = "--enable-keyutils,--disable-keyutils,keyutils"
46PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
47PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
48
49EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath"
50CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
51 ac_cv_printf_positional=yes ac_cv_file__etc_environment=yes \
52 ac_cv_file__etc_TIMEZONE=no"
53
54CFLAGS_append = " -DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
55LDFLAGS_append = " -lpthread"
56
57FILES_${PN} += "${datadir}/gnats"
58FILES_${PN}-doc += "${datadir}/examples"
59FILES_${PN}-dbg += "${libdir}/krb5/plugins/*/.debug"
60
61# As this recipe doesn't inherit update-rc.d, we need to add this dependency here
62RDEPENDS_${PN}_class-target += "initscripts-functions"
63
64do_configure() {
65 gnu-configize --force
66 autoreconf
67 oe_runconf
68}
69
70do_install_append() {
71 rm -rf ${D}/${localstatedir}/run
72
73 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
74 mkdir -p ${D}/${sysconfdir}/init.d ${D}/${sysconfdir}/default
75 install -m 0755 ${WORKDIR}/etc/init.d/* ${D}/${sysconfdir}/init.d
76 install -m 0644 ${WORKDIR}/etc/default/* ${D}/${sysconfdir}/default
77
78 mkdir -p ${D}/${sysconfdir}/default/volatiles
79 echo "d root root 0755 ${localstatedir}/run/krb5kdc none" \
80 > ${D}${sysconfdir}/default/volatiles/87_krb5
81 fi
82 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
83 install -d ${D}${sysconfdir}/tmpfiles.d
84 echo "d /run/krb5kdc - - - -" \
85 > ${D}${sysconfdir}/tmpfiles.d/krb5.conf
86
87 install -d ${D}${systemd_system_unitdir}
88 install -m 0644 ${WORKDIR}/krb5-admin-server.service ${D}${systemd_system_unitdir}
89 install -m 0644 ${WORKDIR}/krb5-kdc.service ${D}${systemd_system_unitdir}
90 fi
91}
92
93pkg_postinst_${PN} () {
94 if [ -z "$D" ]; then
95 if command -v systemd-tmpfiles >/dev/null; then
96 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/krb5.conf
97 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
98 ${sysconfdir}/init.d/populate-volatile.sh update
99 fi
100 fi
101}
102
103BBCLASSEXTEND = "native nativesdk"