summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd/iwd_2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd_2.20.bb')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_2.20.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_2.20.bb b/meta-oe/recipes-connectivity/iwd/iwd_2.20.bb
new file mode 100644
index 000000000..16d900ddc
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd_2.20.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5
6DEPENDS = "dbus"
7
8SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \
9 file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \
10 "
11SRC_URI[sha256sum] = "86827b97cb5b19ddecce36568c59378da2fae8cf37a0e2b9eacd1269f24c6f8e"
12
13inherit autotools manpages pkgconfig python3native systemd
14
15PACKAGECONFIG ??= " \
16 client \
17 monitor \
18 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
19"
20PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
21PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
22PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
23PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
24PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
25PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
26
27SYSTEMD_SERVICE:${PN} = " \
28 iwd.service \
29 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
30"
31
32do_configure:prepend() {
33 install -d ${S}/build-aux
34}
35
36do_install:append() {
37 # If client and monitor are disabled, bindir is empty, causing a QA error
38 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
39}
40
41FILES:${PN} += " \
42 ${datadir}/dbus-1 \
43 ${nonarch_libdir}/modules-load.d \
44 ${systemd_unitdir}/network \
45"
46
47RDEPENDS:${PN} = "dbus"
48
49RRECOMMENDS:${PN} = "\
50 kernel-module-pkcs7-message \
51 kernel-module-pkcs8-key-parser \
52 kernel-module-x509-key-parser \
53"