diff options
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd_1.21.bb')
-rw-r--r-- | meta-oe/recipes-connectivity/iwd/iwd_1.21.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.21.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.21.bb new file mode 100644 index 000000000..834c1d897 --- /dev/null +++ b/meta-oe/recipes-connectivity/iwd/iwd_1.21.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SUMMARY = "Wireless daemon for Linux" | ||
2 | HOMEPAGE = "https://iwd.wiki.kernel.org/" | ||
3 | LICENSE = "LGPL-2.1" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" | ||
5 | |||
6 | DEPENDS = "ell" | ||
7 | |||
8 | SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \ | ||
9 | file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \ | ||
10 | " | ||
11 | SRC_URI[sha256sum] = "bac891df91c605271e91b73cf0015e1ba86ff784347e53fc67601366859b3851" | ||
12 | |||
13 | inherit autotools manpages pkgconfig python3native systemd | ||
14 | |||
15 | PACKAGECONFIG ??= " \ | ||
16 | client \ | ||
17 | monitor \ | ||
18 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | ||
19 | " | ||
20 | PACKAGECONFIG[client] = "--enable-client,--disable-client,readline" | ||
21 | PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor" | ||
22 | PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native" | ||
23 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" | ||
24 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" | ||
25 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" | ||
26 | |||
27 | EXTRA_OECONF = "--enable-external-ell" | ||
28 | |||
29 | SYSTEMD_SERVICE:${PN} = " \ | ||
30 | iwd.service \ | ||
31 | ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \ | ||
32 | " | ||
33 | |||
34 | do_configure:prepend() { | ||
35 | install -d ${S}/build-aux | ||
36 | } | ||
37 | |||
38 | do_install:append() { | ||
39 | # If client and monitor are disabled, bindir is empty, causing a QA error | ||
40 | rmdir --ignore-fail-on-non-empty ${D}/${bindir} | ||
41 | } | ||
42 | |||
43 | FILES:${PN} += " \ | ||
44 | ${datadir}/dbus-1 \ | ||
45 | ${nonarch_libdir}/modules-load.d \ | ||
46 | ${systemd_unitdir}/network \ | ||
47 | " | ||
48 | |||
49 | RDEPENDS:${PN} = "dbus" | ||
50 | |||
51 | RRECOMMENDS:${PN} = "\ | ||
52 | kernel-module-pkcs7-message \ | ||
53 | kernel-module-pkcs8-key-parser \ | ||
54 | kernel-module-x509-key-parser \ | ||
55 | " | ||