diff options
Diffstat (limited to 'meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb')
-rw-r--r-- | meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb | 100 |
1 files changed, 0 insertions, 100 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb deleted file mode 100644 index 1a7857544..000000000 --- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb +++ /dev/null | |||
@@ -1,100 +0,0 @@ | |||
1 | DESCRIPTION = "GNU Radio" | ||
2 | URL = "http://gnuradio.org" | ||
3 | SECTION = "apps" | ||
4 | LICENSE = "GPLv3" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | |||
7 | DEPENDS = "gsl fftwf python alsa-lib boost cppunit \ | ||
8 | swig-native python-numpy python-cheetah-native orc" | ||
9 | |||
10 | #Available PACKAGECONFIG options are qt grc uhd | ||
11 | PACKAGECONFIG ??= "qtgui grc uhd" | ||
12 | |||
13 | PACKAGECONFIG[uhd] = "-DENABLE_GR_UHD=ON,-DENABLE_GR_UHD=OFF,uhd," | ||
14 | PACKAGECONFIG[grc] = "-DENABLE_GRC=ON,-DENABLE_GRC=OFF,python-pygtk python-cheetah, " | ||
15 | |||
16 | PACKAGECONFIG[qtgui] = "-DENABLE_GR_QTGUI=ON,-DENABLE_GR_QTGUI=OFF,qt4-x11-free qwt, " | ||
17 | |||
18 | |||
19 | inherit distutils-base cmake pkgconfig | ||
20 | |||
21 | export BUILD_SYS | ||
22 | export HOST_SYS="${MULTIMACH_TARGET_SYS}" | ||
23 | |||
24 | RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \ | ||
25 | python-lang python-textutils python-shell python-pickle \ | ||
26 | python-compiler python-pkgutil python-pydoc python-mmap \ | ||
27 | python-netclient python-difflib \ | ||
28 | python-pprint python-numpy \ | ||
29 | " | ||
30 | RDEPENDS_${PN}-grc = "python-pygtk python-lxml python-cheetah python-netserver" | ||
31 | |||
32 | C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
33 | |||
34 | do_configure_prepend() { | ||
35 | ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm | ||
36 | echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt | ||
37 | echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt | ||
38 | echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt | ||
39 | } | ||
40 | |||
41 | do_compile_prepend() { | ||
42 | cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2 | ||
43 | } | ||
44 | |||
45 | PACKAGES += " \ | ||
46 | ${PN}-grc \ | ||
47 | ${PN}-examples \ | ||
48 | " | ||
49 | |||
50 | FILES_${PN}-grc = "${datadir}/gnuradio/grc" | ||
51 | FILES_${PN}-examples = "${datadir}/gnuradio/examples" | ||
52 | |||
53 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/gnuradio" | ||
54 | FILES_${PN} += "${datadir}/gnuradio/modtool" | ||
55 | # The following needs fixing upstream | ||
56 | FILES_${PN} += "${prefix}/etc/gnuradio" | ||
57 | |||
58 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \ | ||
59 | ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \ | ||
60 | ${datadir}/gnuradio/examples/*/.debug \ | ||
61 | " | ||
62 | |||
63 | PV = "3.6.5" | ||
64 | |||
65 | FILESPATHPKG_prepend = "gnuradio-git:" | ||
66 | |||
67 | SRCREV = "a7b3a9339106aaba72195b693dfeaa98f194e0d5" | ||
68 | |||
69 | # Make it easy to test against developer repos and branches | ||
70 | GIT_REPO = "gnuradio.git" | ||
71 | GIT_BRANCH = "master" | ||
72 | |||
73 | SRC_URI = "git://git.gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH} \ | ||
74 | file://0001-gr-trellis-Kill-docs-hard.patch \ | ||
75 | " | ||
76 | |||
77 | S="${WORKDIR}/git" | ||
78 | |||
79 | OECMAKE_BUILDPATH = "${S}/build" | ||
80 | OECMAKE_SOURCEPATH = "${S}" | ||
81 | |||
82 | EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE \ | ||
83 | -DENABLE_GR_FCD=OFF \ | ||
84 | -DENABLE_GR_WXGUI=OFF \ | ||
85 | -DENABLE_GR_VIDEO_SDL=OFF \ | ||
86 | -DENABLE_SPHINX=OFF -DENABLE_DOXYGEN=OFF \ | ||
87 | -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt \ | ||
88 | -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 \ | ||
89 | -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore \ | ||
90 | -DQT_LIBRARY_DIR=${STAGING_LIBDIR} \ | ||
91 | -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so \ | ||
92 | -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so \ | ||
93 | ${@base_contains('TUNE_FEATURES', 'neon', \ | ||
94 | '-Dhave_mfpu_neon=1', '-Dhave_mfpu_neon=0', d)} \ | ||
95 | " | ||
96 | |||
97 | inherit distutils-base cmake pkgconfig | ||
98 | |||
99 | EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" | ||
100 | |||