summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb')
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb b/meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb
new file mode 100644
index 000000000..928781063
--- /dev/null
+++ b/meta-oe/recipes-connectivity/bluez/bluez4_4.93.bb
@@ -0,0 +1,72 @@
1SUMMARY = "Linux Bluetooth Stack Userland V4"
2DESCRIPTION = "Linux Bluetooth stack V4 userland components. These include a system configurations, daemons, tools and system libraries."
3HOMEPAGE = "http://www.bluez.org"
4SECTION = "libs"
5PRIORITY = "optional"
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
8 file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
9 file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
10 file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
11DEPENDS = "gst-plugins-base alsa-lib libusb dbus-glib libnl"
12RDEPENDS_${PN}-dev = "bluez-hcidump"
13
14ASNEEDED = ""
15
16PR = "r0"
17
18# to find bluez patches from oe-core
19FILESPATH =. "${COREBASE}/meta/recipes-connectivity/bluez/bluez4-4.82/:"
20SRC_URI = "\
21 ${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.gz \
22 file://fix-dfutool-usb-declaration-mismatch.patch \
23 file://bluetooth.conf \
24"
25SRC_URI[md5sum] = "c0f6450a39809996306005f5b85c6d3d"
26SRC_URI[sha256sum] = "ad370dbc8c4d37a0cc3d5078d62542f0e53a33f5b2df849cf7601ef25c5e6087"
27
28
29S = "${WORKDIR}/bluez-${PV}"
30
31inherit autotools
32
33EXTRA_OECONF = "\
34 --enable-gstreamer \
35 --enable-alsa \
36 --enable-usb \
37 --enable-tools \
38 --enable-bccmd \
39 --enable-hid2hci \
40 --enable-dfutool \
41 --enable-hidd \
42 --enable-pand \
43 --enable-dund \
44 --disable-cups \
45 --enable-test \
46 --enable-configfiles \
47"
48
49do_install_append() {
50 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
51 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
52 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
53 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
54 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
55}
56
57PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
58
59FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
60FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
61FILES_${PN} += "${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/"
62FILES_${PN}-dev += "\
63 ${libdir}/bluetooth/plugins/*.la \
64 ${libdir}/alsa-lib/*.la \
65 ${libdir}/gstreamer-0.10/*.la \
66"
67
68FILES_${PN}-dbg += "\
69 ${libdir}/bluetooth/plugins/.debug \
70 ${libdir}/*/.debug \
71 ${base_libdir}/udev/.debug \
72"