summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb')
-rw-r--r--meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb b/meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb
new file mode 100644
index 000000000..17445ac2d
--- /dev/null
+++ b/meta-oe/recipes-bsp/flashrom/flashrom_1.2.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPLv2"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6DEPENDS = "pciutils libusb libusb-compat"
7
8SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \
9 "
10SRC_URI[md5sum] = "7f8e4b87087eb12ecee0fcc5445b4956"
11SRC_URI[sha256sum] = "e1f8d95881f5a4365dfe58776ce821dfcee0f138f75d0f44f8a3cd032d9ea42b"
12
13S = "${WORKDIR}/flashrom-v${PV}"
14
15inherit pkgconfig
16
17do_install() {
18 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
19}