summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb')
-rw-r--r--meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb b/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
new file mode 100644
index 000000000..2c0914d30
--- /dev/null
+++ b/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Userspace helper for Linux kernel EDAC drivers"
2HOMEPAGE = "https://github.com/grondo/edac-utils"
3SECTION = "Applications/System"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7DEPENDS = " sysfsutils"
8
9SRCREV = "f9aa96205f610de39a79ff43c7478b7ef02e3138"
10PV = "0.18+git${SRCPV}"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/grondo/edac-utils \
15 file://make-init-script-be-able-to-automatically-load-EDAC-.patch \
16 file://add-restart-to-initscript.patch \
17 file://edac.service \
18"
19
20inherit autotools-brokensep systemd
21
22do_configure_prepend () {
23 touch ${S}/ChangeLog
24 ${S}/bootstrap
25}
26
27RDEPENDS_${PN}_x86 = "dmidecode"
28RDEPENDS_${PN}_x86-64 = "dmidecode"
29RDEPENDS_${PN}_arm = "dmidecode"
30RDEPENDS_${PN}_aarch64 = "dmidecode"
31RDEPENDS_${PN}_powerpc = "dmidecode"
32RDEPENDS_${PN}_powerpc64 = "dmidecode"
33RDEPENDS_${PN}_append = " \
34 perl-module-file-basename perl-module-file-find perl-module-getopt-long perl-module-posix \
35 perl-module-overload \
36 perl-module-overloading \
37 perl-module-file-glob \
38"
39
40do_install_append() {
41 install -d ${D}${systemd_unitdir}/system
42 install -m 644 ${WORKDIR}/edac.service ${D}/${systemd_unitdir}/system
43 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}/${systemd_unitdir}/system/edac.service
44}
45
46SYSTEMD_SERVICE_${PN} = "edac.service"
47SYSTEMD_AUTO_ENABLE_${PN} = "disable"