diff options
Diffstat (limited to 'meta-oe/recipes-benchmark/memtester')
-rw-r--r-- | meta-oe/recipes-benchmark/memtester/files/Makefile.patch | 15 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb | 27 |
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/memtester/files/Makefile.patch b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch new file mode 100644 index 000000000..57a04642a --- /dev/null +++ b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: memtester-4.0.5/Makefile | ||
2 | =================================================================== | ||
3 | --- memtester-4.0.5.orig/Makefile 2005-03-14 06:02:30.000000000 -0800 | ||
4 | +++ memtester-4.0.5/Makefile 2006-07-08 23:53:42.000000000 -0700 | ||
5 | @@ -24,8 +24,8 @@ | ||
6 | auto-ccld.sh: \ | ||
7 | conf-cc conf-ld warn-auto.sh | ||
8 | ( cat warn-auto.sh; \ | ||
9 | - echo CC=\'`head -1 conf-cc`\'; \ | ||
10 | - echo LD=\'`head -1 conf-ld`\' \ | ||
11 | + echo CC=\'`head -n 1 conf-cc`\'; \ | ||
12 | + echo LD=\'`head -n 1 conf-ld`\' \ | ||
13 | ) > auto-ccld.sh | ||
14 | |||
15 | compile: \ | ||
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb new file mode 100644 index 000000000..9f4e53e80 --- /dev/null +++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SECTION = "console/utils" | ||
2 | DESCRIPTION = "Utility to test for faulty memory subsystem" | ||
3 | LICENSE = "GPLv2" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | ||
6 | |||
7 | SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz" | ||
8 | SRC_URI += "file://Makefile.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38" | ||
11 | SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6" | ||
12 | |||
13 | S = "${WORKDIR}/memtester-${PV}" | ||
14 | |||
15 | do_compile () { | ||
16 | echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc | ||
17 | echo '${CC} ${LDFLAGS}' > conf-ld | ||
18 | oe_runmake | ||
19 | } | ||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${bindir} | ||
23 | install -d ${D}${mandir}/man8 | ||
24 | install -m 0755 memtester ${D}${bindir}/ | ||
25 | install -m 0755 memtester.8 ${D}${mandir}/man8/ | ||
26 | } | ||
27 | |||