summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch13
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch9
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb6
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
index 53f35abb7..34a62207e 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
@@ -10,15 +10,17 @@ Upstream-Status: Submitted
10 10
11Signed-off-by: Ting Liu <b28495@freescale.com> 11Signed-off-by: Ting Liu <b28495@freescale.com>
12 12
13Update for 2.22.
14Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
13--- 15---
14 tests/run_tests.py | 12 +++++++++++- 16 tests/run_tests.py | 12 +++++++++++-
15 1 file changed, 11 insertions(+), 1 deletion(-) 17 1 file changed, 11 insertions(+), 1 deletion(-)
16 18
17diff --git a/tests/run_tests.py b/tests/run_tests.py 19diff --git a/tests/run_tests.py b/tests/run_tests.py
18index 3c95a03..560df6b 100755 20index 018264d..0aabcd1 100755
19--- a/tests/run_tests.py 21--- a/tests/run_tests.py
20+++ b/tests/run_tests.py 22+++ b/tests/run_tests.py
21@@ -234,9 +234,19 @@ def get_pagesizes(): 23@@ -245,9 +245,19 @@ def get_pagesizes():
22 Use libhugetlbfs' hugeadm utility to get a list of page sizes that have 24 Use libhugetlbfs' hugeadm utility to get a list of page sizes that have
23 active mount points and at least one huge page allocated to the pool. 25 active mount points and at least one huge page allocated to the pool.
24 """ 26 """
@@ -36,6 +38,9 @@ index 3c95a03..560df6b 100755
36+ return sizes 38+ return sizes
37+ out = p.stdout.read().strip() 39+ out = p.stdout.read().strip()
38+ 40+
39 if rc != 0 or out == "": return sizes 41 if rc != 0 or out == "":
42 return sizes
40 43
41 for size in out.split("\n"): sizes.add(int(size)) 44--
452.7.4
46
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch
index 08174200d..e736cbc79 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch
@@ -8,12 +8,14 @@ error: unknown type name 'ino_t'; did you mean 'int'?
8 8
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10 10
11Update for 2.22.
12Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
11--- 13---
12 tests/hugetests.h | 1 + 14 tests/hugetests.h | 1 +
13 1 file changed, 1 insertion(+) 15 1 file changed, 1 insertion(+)
14 16
15diff --git a/tests/hugetests.h b/tests/hugetests.h 17diff --git a/tests/hugetests.h b/tests/hugetests.h
16index 8b1d8d9..056042c 100644 18index bc4e16a..fbe4dc0 100644
17--- a/tests/hugetests.h 19--- a/tests/hugetests.h
18+++ b/tests/hugetests.h 20+++ b/tests/hugetests.h
19@@ -22,6 +22,7 @@ 21@@ -22,6 +22,7 @@
@@ -21,6 +23,9 @@ index 8b1d8d9..056042c 100644
21 #include <errno.h> 23 #include <errno.h>
22 #include <string.h> 24 #include <string.h>
23+#include <dirent.h> 25+#include <dirent.h>
26 #include <unistd.h>
24 27
25 #include "libhugetlbfs_privutils.h" 28 #include "libhugetlbfs_privutils.h"
26 #include "libhugetlbfs_testprobes.h" 29--
302.7.4
31
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 66fd8e21d..f25812279 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -5,12 +5,12 @@ LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
5 5
6DEPENDS = "sysfsutils" 6DEPENDS = "sysfsutils"
7RDEPENDS_${PN} += "bash python python-io python-lang python-subprocess python-resource" 7RDEPENDS_${PN} += "bash python python-io python-lang python-subprocess python-resource"
8RDEPENDS_${PN}-tests += "bash" 8RDEPENDS_${PN}-tests += "bash python3-core"
9 9
10PV = "2.21" 10PV = "2.22"
11PE = "1" 11PE = "1"
12 12
13SRCREV = "73d06e69108f231696e9c5c44f4b42690fc5d752" 13SRCREV = "e6499ff92b4a7dcffbd131d1f5d24933e48c3f20"
14SRC_URI = " \ 14SRC_URI = " \
15 git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ 15 git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \
16 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ 16 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \