summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 5ee6e8e14..5645add6b 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -5,23 +5,23 @@ LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
5DEPENDS = "sysfsutils perl" 5DEPENDS = "sysfsutils perl"
6RDEPENDS_${PN} += "python python-io python-lang python-subprocess python-resource" 6RDEPENDS_${PN} += "python python-io python-lang python-subprocess python-resource"
7 7
8SRCBRANCH = "next" 8SRCREV = "ea3f6b273f535aab38cefae30030774457bbbfe6"
9SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code;branch=${SRCBRANCH} \ 9SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
10 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ 10 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
11 file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \ 11 file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \
12 file://fix-lib64-can-not-be-shiped-in-64bit-target.patch \
13 file://tests-Makefile-install-static-4G-edge-testcases.patch \ 12 file://tests-Makefile-install-static-4G-edge-testcases.patch \
14 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ 13 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
15 file://0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch \ 14 file://0001-aarch64-fix-cross-compilation.patch \
15 file://0001-aarch64-fix-page-size-not-properly-computed.patch \
16 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
16" 17"
17SRCREV = "6824d18d5f33fdab445a8eff147fcdb6361f5791"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*" 21COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*"
22 22
23 23LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
24EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' BUILDTYPE=NATIVEONLY ${LIBARGS}" 24EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"
25CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0" 25CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
26 26
27TARGET_CC_ARCH += "${LDFLAGS}" 27TARGET_CC_ARCH += "${LDFLAGS}"
@@ -31,6 +31,9 @@ do_configure() {
31 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then 31 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
32 sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile 32 sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
33 fi 33 fi
34
35 # fixup perl module directory hardcoded to perl5
36 sed -i 's/perl5/perl/g' Makefile
34} 37}
35 38
36do_install() { 39do_install() {