summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
new file mode 100644
index 000000000..0b8d0e4d5
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
@@ -0,0 +1,39 @@
1Upstream-Status: Inappropriate [oe-core specific]
2
3libhugetlbfs depends on perl, and perl installs a directory 'perl'
4and make a symlink 'perl5' to it. So just install perl libs in
5libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid
6the following error:
7| CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir
8| -ps . | tar -xf - -C .../tmp/sysroots/t4240qds'
9| returned non-zero exit status 2 with output
10| tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists
11| tar: Exiting with failure status due to previous errors
12
13
14Signed-off-by: Ting Liu <b28495@freescale.com>
15
16--- a/Makefileold 2013-10-11 23:07:31.759421318 -0500
17+++ b/Makefile 2013-10-11 23:08:01.935571122 -0500
18@@ -173,17 +173,17 @@
19 DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
20
21 ifdef CC32
22-PMDIR = $(PREFIX)/lib/perl5/TLBC
23+PMDIR = $(PREFIX)/lib/perl/TLBC
24 endif
25
26 ifdef CC64
27 ifeq ($(ARCH),x86_64)
28-PMDIR = $(PREFIX)/lib/perl5/TLBC
29+PMDIR = $(PREFIX)/lib/perl/TLBC
30 else
31 ifeq ($(ARCH),aarch64)
32-PMDIR = $(PREFIX)/lib/perl5/TLBC
33+PMDIR = $(PREFIX)/lib/perl/TLBC
34 else
35-PMDIR = $(PREFIX)/lib64/perl5/TLBC
36+PMDIR = $(PREFIX)/lib64/perl/TLBC
37 endif
38 endif
39 endif