summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/iozone3/iozone3_263.bb')
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_263.bb111
1 files changed, 111 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
new file mode 100644
index 000000000..c1aa7fb3e
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
@@ -0,0 +1,111 @@
1DESCRIPTION = "Filesystem and Disk Benchmarking Tool"
2HOMEPAGE = "http://www.iozone.org/"
3AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>"
4SECTION = "console/tests"
5LICENSE = "iozone3"
6LIC_FILES_CHKSUM = "file://iozone.c;beginline=237;endline=241;md5=ab42a6185fd0443978871f11a007ac0b"
7
8
9SRC_URI = "http://www.iozone.org/src/current/iozone3_263.tar \
10 file://copyright.txt \
11 file://fileop-arm.patch \
12 "
13SRC_URI[md5sum] = "44fd88df361ec4508e10c8d6615245fa"
14SRC_URI[sha256sum] = "920fde1a3843539570e2df4aa611e74df102e52d363c5973d5a9d15bdf976461"
15
16S = "${WORKDIR}/${PN}_${PV}/src/current/"
17
18EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}'"
19EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}'"
20EXTRA_OEMAKE_arm = "linux-arm CC='${CC}'"
21EXTRA_OEMAKE = "linux CC='${CC}'"
22
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25do_install() {
26 install -d ${D}${bindir} \
27 ${D}${mandir}/man1 \
28 ${D}${datadir}/doc/${PN}/examples
29
30 install -m 0755 ${S}/iozone ${D}${bindir}
31 install -m 0755 ${S}/fileop ${D}${bindir}
32 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
33 install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/
34
35 install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples
36 install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples
37 install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples
38
39 install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples
40 install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples
41 install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples
42
43 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/
44 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/
45 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/
46}
47
48FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
49
50# LICENSE:
51#
52# Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott
53#
54# License to freely use and distribute this software is hereby granted
55# by the author, subject to the condition that this copyright notice
56# remains intact. The author retains the exclusive right to publish
57# derivative works based on this work, including, but not limited to
58# revised versions of this work.
59#
60
61#
62# Below is author reply to question about distributing iozone3 in
63# OpenEmbedded:
64#
65# ========================================================================
66#
67# Marcin,
68#
69# Re-distribution is permitted as long as the copyright is
70# maintained and the source code is not changed. I do not
71# see a problem with your mods to enable fileop for Linux-arm,
72# as these mods have been returned to the Iozone folks,
73# and they have been accepted for inclusion in the next
74# release :-)
75#
76# Thank you for your contribution,
77# Don Capps
78#
79# ----- Original Message -----
80# From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
81# To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
82# <wnorcott@us.oracle.com>
83# Sent: Sunday, October 29, 2006 4:55 PM
84# Subject: iozone3 263 patch for arm and License question
85#
86#
87# > Morning
88# >
89# > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
90# > other developers. Currently OE is used to build few distributions for
91# > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
92# > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
93# >
94# > According to your distribution of derivations is forbidden. Packaging
95# > iozone3 in OpenEmbedded will not involve any source code changes. But
96# > when I was building it for ARM I discovered that fileop binary was not
97# > built - so I created patch for it (attached). Not yet tested it on target
98# > device.
99# >
100# > Thus, I seek your written permission via e-mail to distribute a package of
101# > the unmodified source code and also a package of the pre-compiled binary.
102# > Your copyright statement will be included in the package.
103# >
104# >
105# > 1. http://www.openembedded.org/
106# >
107# > Regards
108# > --
109# > JID: hrw-jabber.org
110# > OpenEmbedded developer/consultant
111