summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb
new file mode 100644
index 000000000..3ff0449bd
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb
@@ -0,0 +1,34 @@
1SUMMARY = "OpenGL (ES) 2.0 benchmark"
2DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \
3It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
4HOMEPAGE = "https://launchpad.net/glmark2"
5BUGTRACKER = "https://bugs.launchpad.net/glmark2"
6
7LICENSE = "GPLv3+ & SGIv1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9 file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
10
11DEPENDS = "libpng12 jpeg"
12
13SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
14
15SRC_URI[md5sum] = "739859cf57d4c8a23452c43e84f66e56"
16SRC_URI[sha256sum] = "bded41aaf918ce062d9b81e42cc5be943e6a80bc4ff9d046983b96102c3df6b5"
17
18inherit waf pkgconfig
19
20PACKAGECONFIG ?= "gl gles2"
21
22PACKAGECONFIG[gl] = ",,virtual/libgl"
23PACKAGECONFIG[gles2] = ",,virtual/libgles2"
24
25python __anonymous() {
26 packageconfig = (d.getVar("PACKAGECONFIG", True) or "").split()
27 flavors = []
28 if "gles2" in packageconfig:
29 flavors.append("x11-glesv2")
30 if "gl" in packageconfig:
31 flavors.append("x11-gl")
32 if flavors:
33 d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
34}