diff options
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_3.27.bb')
-rw-r--r-- | meta-oe/recipes-benchmark/fio/fio_3.27.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.27.bb b/meta-oe/recipes-benchmark/fio/fio_3.27.bb new file mode 100644 index 000000000..d18649db0 --- /dev/null +++ b/meta-oe/recipes-benchmark/fio/fio_3.27.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Filesystem and hardware benchmark and stress tool" | ||
2 | DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \ | ||
3 | stress/hardware verification. It has support for a number of I/O engines, \ | ||
4 | I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \ | ||
5 | and much more. It can work on block devices as well as files. fio accepts \ | ||
6 | job descriptions in a simple-to-understand text format. Several example job \ | ||
7 | files are included. fio displays all sorts of I/O performance information." | ||
8 | HOMEPAGE = "http://freecode.com/projects/fio" | ||
9 | SECTION = "console/tests" | ||
10 | LICENSE = "GPLv2" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
12 | |||
13 | DEPENDS = "libaio zlib coreutils-native" | ||
14 | DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}" | ||
15 | RDEPENDS_${PN} = "python3-core bash" | ||
16 | |||
17 | PACKAGECONFIG_NUMA = "numa" | ||
18 | # ARM does not currently support NUMA | ||
19 | PACKAGECONFIG_NUMA_arm = "" | ||
20 | PACKAGECONFIG_NUMA_armeb = "" | ||
21 | |||
22 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" | ||
23 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" | ||
24 | |||
25 | SRCREV = "0313e938c9c8bb37d71dade239f1f5326677b079" | ||
26 | SRC_URI = "git://git.kernel.dk/fio.git \ | ||
27 | " | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | # avoids build breaks when using no-static-libs.inc | ||
32 | DISABLE_STATIC = "" | ||
33 | |||
34 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" | ||
35 | EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}" | ||
36 | |||
37 | do_configure() { | ||
38 | ./configure ${EXTRA_OECONF} | ||
39 | } | ||
40 | |||
41 | do_install() { | ||
42 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} | ||
43 | install -d ${D}/${docdir}/${PN} | ||
44 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ | ||
45 | } | ||