diff options
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_3.16.bb')
-rw-r--r-- | meta-oe/recipes-benchmark/fio/fio_3.16.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.16.bb b/meta-oe/recipes-benchmark/fio/fio_3.16.bb new file mode 100644 index 000000000..092b2bead --- /dev/null +++ b/meta-oe/recipes-benchmark/fio/fio_3.16.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Filesystem and hardware benchmark and stress tool" | ||
2 | DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \ | ||
3 | stress/hardware verification. It has support for a number of I/O engines, \ | ||
4 | I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \ | ||
5 | and much more. It can work on block devices as well as files. fio accepts \ | ||
6 | job descriptions in a simple-to-understand text format. Several example job \ | ||
7 | files are included. fio displays all sorts of I/O performance information." | ||
8 | HOMEPAGE = "http://freecode.com/projects/fio" | ||
9 | SECTION = "console/tests" | ||
10 | LICENSE = "GPLv2" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
12 | |||
13 | DEPENDS = "libaio zlib" | ||
14 | RDEPENDS_${PN} = "python bash" | ||
15 | |||
16 | PACKAGECONFIG_NUMA = "numa" | ||
17 | # ARM does not currently support NUMA | ||
18 | PACKAGECONFIG_NUMA_arm = "" | ||
19 | PACKAGECONFIG_NUMA_armeb = "" | ||
20 | |||
21 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" | ||
22 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" | ||
23 | |||
24 | SRCREV = "92f75708b530989fdb13b50be6604f44b80d038d" | ||
25 | SRC_URI = "git://git.kernel.dk/fio.git \ | ||
26 | file://0001-update-the-interpreter-paths.patch \ | ||
27 | " | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | # avoids build breaks when using no-static-libs.inc | ||
32 | DISABLE_STATIC = "" | ||
33 | |||
34 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" | ||
35 | EXTRA_OECONF = "--disable-optimizations" | ||
36 | |||
37 | do_configure() { | ||
38 | ./configure ${EXTRA_OECONF} | ||
39 | } | ||
40 | |||
41 | do_install() { | ||
42 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} | ||
43 | install -d ${D}/${docdir}/${PN} | ||
44 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ | ||
45 | } | ||