summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/fio/fio_3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_3.12.bb')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.12.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.12.bb b/meta-oe/recipes-benchmark/fio/fio_3.12.bb
new file mode 100644
index 000000000..2deb42db9
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_3.12.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13DEPENDS = "libaio zlib"
14RDEPENDS_${PN} = "python bash"
15
16PACKAGECONFIG_NUMA = "numa"
17# ARM does not currently support NUMA
18PACKAGECONFIG_NUMA_arm = ""
19
20PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
21PACKAGECONFIG[numa] = ",--disable-numa,numactl"
22
23# rev for v3.8
24SRCREV = "16500b5a0b03ee0142d592bb74a46943a223b06e"
25SRC_URI = "git://git.kernel.dk/fio.git \
26 file://0001-update-the-interpreter-paths.patch \
27"
28
29S = "${WORKDIR}/git"
30
31# avoids build breaks when using no-static-libs.inc
32DISABLE_STATIC = ""
33
34EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
35EXTRA_OECONF = "--disable-optimizations"
36
37do_configure() {
38 ./configure ${EXTRA_OECONF}
39}
40
41do_install() {
42 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
43 install -d ${D}/${docdir}/${PN}
44 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
45}