summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch99
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch38
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/0001-not-check-pandoc.patch26
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.3.13.bb (renamed from meta-networking/recipes-support/dovecot/dovecot_2.2.36.4.bb)12
4 files changed, 85 insertions, 90 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
index f86235076e..f16f687f24 100644
--- a/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
+++ b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
@@ -9,58 +9,65 @@ Upstream-Status: pending
9 9
10Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 10Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
11Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> 11Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
12
13Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
12--- 14---
13 configure.ac | 15 +++++---------- 15 m4/glibc.m4 | 6 ++----
14 1 file changed, 5 insertions(+), 10 deletions(-) 16 m4/ioloop.m4 | 9 +++------
17 2 files changed, 5 insertions(+), 10 deletions(-)
15 18
16diff --git a/configure.ac b/configure.ac 19diff --git a/m4/glibc.m4 b/m4/glibc.m4
17index 3b32614..94ec002 100644 20index 5d722aa..ce088d3 100644
18--- a/configure.ac 21--- a/m4/glibc.m4
19+++ b/configure.ac 22+++ b/m4/glibc.m4
20@@ -519,13 +519,10 @@ have_ioloop=no 23@@ -17,7 +17,7 @@ AC_DEFUN([DOVECOT_GLIBC], [
21 24 dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
22 if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then 25 dnl * It may also be broken in AIX.
23 AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[ 26 AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
24- AC_TRY_RUN([ 27- AC_TRY_RUN([
25+ AC_TRY_LINK([ 28+ AC_TRY_LINK([
26 #include <sys/epoll.h> 29 #define _XOPEN_SOURCE 600
27- 30 #include <stdio.h>
28- int main() 31 #include <stdlib.h>
29- { 32@@ -26,7 +26,7 @@ AC_DEFUN([DOVECOT_GLIBC], [
30- return epoll_create(5) < 1; 33 #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
34 possibly broken posix_fallocate
35 #endif
36- int main() {
37+ ], [
38 int fd = creat("conftest.temp", 0600);
39 int ret;
40 if (fd == -1) {
41@@ -35,8 +35,6 @@ AC_DEFUN([DOVECOT_GLIBC], [
42 }
43 ret = posix_fallocate(fd, 1024, 1024) < 0 ? 1 : 0;
44 unlink("conftest.temp");
45- return ret;
31- } 46- }
32+ ], [
33+ epoll_create(5) < 1;
34 ], [ 47 ], [
35 i_cv_epoll_works=yes 48 i_cv_posix_fallocate_works=yes
36 ], [ 49 ], [
37@@ -653,7 +650,7 @@ fi 50diff --git a/m4/ioloop.m4 b/m4/ioloop.m4
38 dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it. 51index 0f7dde0..f40fd62 100644
39 dnl * It may also be broken in AIX. 52--- a/m4/ioloop.m4
40 AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[ 53+++ b/m4/ioloop.m4
41- AC_TRY_RUN([ 54@@ -4,13 +4,10 @@ AC_DEFUN([DOVECOT_IOLOOP], [
42+ AC_TRY_LINK([ 55
43 #define _XOPEN_SOURCE 600 56 if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
44 #include <stdio.h> 57 AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
45 #include <stdlib.h> 58- AC_TRY_RUN([
46@@ -662,7 +659,7 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[ 59+ AC_TRY_LINK([
47 #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7) 60 #include <sys/epoll.h>
48 possibly broken posix_fallocate 61-
49 #endif 62- int main()
50- int main() { 63- {
51+ ], [ 64- return epoll_create(5) < 1;
52 int fd = creat("conftest.temp", 0600); 65- }
53 int ret; 66+ ], [
54 if (fd == -1) { 67+ epoll_create(5) < 1;
55@@ -671,8 +668,6 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[ 68 ], [
56 } 69 i_cv_epoll_works=yes
57 ret = posix_fallocate(fd, 1024, 1024) < 0 ? 1 : 0; 70 ], [
58 unlink("conftest.temp");
59- return ret;
60- }
61 ], [
62 i_cv_posix_fallocate_works=yes
63 ], [
64-- 71--
651.8.4.2 722.25.1
66 73
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch
deleted file mode 100644
index 65ae9bf910..0000000000
--- a/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From be9b3809b86fe593dbb16f0b981b3d315a27b799 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 22 Oct 2017 22:10:41 -0700
4Subject: [PATCH] doveadm: Fix parallel build
5
6Sometimes dovetail build fails with errors like
7
8doveadm-util.o: file not recognized: File truncated
9collect2: error: ld returned 1 exit status
10make[4]: *** [Makefile:812: test-doveadm-util] Error 1
11
12This is partial backport from
13
14https://github.com/dovecot/core/commit/b200bc3875fa06d42c8619865cc306c3297fcacc
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 src/doveadm/Makefile.am | 4 ++--
19 1 file changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/src/doveadm/Makefile.am b/src/doveadm/Makefile.am
22index c644646..6ae9144 100644
23--- a/src/doveadm/Makefile.am
24+++ b/src/doveadm/Makefile.am
25@@ -180,8 +180,8 @@ test_libs = \
26 ../lib/liblib.la
27 test_deps = $(noinst_LTLIBRARIES) $(test_libs)
28
29-test_doveadm_util_SOURCES = test-doveadm-util.c
30-test_doveadm_util_LDADD = doveadm-util.o $(test_libs) $(MODULE_LIBS)
31+test_doveadm_util_SOURCES = doveadm-util.c test-doveadm-util.c
32+test_doveadm_util_LDADD = $(test_libs) $(MODULE_LIBS)
33 test_doveadm_util_DEPENDENCIES = $(test_deps)
34
35 check: check-am check-test
36--
372.14.2
38
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-not-check-pandoc.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-not-check-pandoc.patch
new file mode 100644
index 0000000000..20ba73a824
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot/0001-not-check-pandoc.patch
@@ -0,0 +1,26 @@
1From 8c7d143ff28441c8b74b0f518dd2281239aede3d Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Fri, 15 Jan 2021 11:10:22 +0900
4Subject: [PATCH] not check pandoc
5
6Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
7---
8 m4/dovecot.m4 | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/m4/dovecot.m4 b/m4/dovecot.m4
12index 2b5d895..ece8489 100644
13--- a/m4/dovecot.m4
14+++ b/m4/dovecot.m4
15@@ -447,7 +447,7 @@ AC_DEFUN([DC_PANDOC], [
16 dnl Optional tool for making documentation
17 AC_CHECK_PROGS(PANDOC, [pandoc], [true])
18
19- AS_IF([test "$PANDOC" = "true"], [
20+ AS_IF([test "$PANDOC" = "false"], [
21 AS_IF([test ! -e README], [
22 AC_MSG_ERROR([Cannot produce documentation without pandoc - disable with PANDOC=false ./configure])
23 ])
24--
252.25.1
26
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.36.4.bb b/meta-networking/recipes-support/dovecot/dovecot_2.3.13.bb
index bda1740234..c78d283d25 100644
--- a/meta-networking/recipes-support/dovecot/dovecot_2.2.36.4.bb
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.3.13.bb
@@ -3,19 +3,19 @@ HOMEPAGE = "https://www.dovecot.org/"
3DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory." 3DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
4SECTION = "mail" 4SECTION = "mail"
5LICENSE = "LGPLv2.1 & MIT" 5LICENSE = "LGPLv2.1 & MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b" 6LIC_FILES_CHKSUM = "file://COPYING;md5=2956560272e5b31d9d64f03111732048"
7 7
8SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \ 8SRC_URI = "http://dovecot.org/releases/2.3/dovecot-${PV}.tar.gz \
9 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \ 9 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
10 file://dovecot.service \ 10 file://dovecot.service \
11 file://dovecot.socket \ 11 file://dovecot.socket \
12 file://0001-doveadm-Fix-parallel-build.patch \ 12 file://0001-not-check-pandoc.patch \
13 " 13 "
14 14
15SRC_URI[md5sum] = "66c4d71858b214afee5b390ee602dee2" 15SRC_URI[md5sum] = "f512bf1a4dac9ac994fddfb6bc5068ff"
16SRC_URI[sha256sum] = "777c61e264869e9b288b8d6603f4ed3ac3aac9ec573908067353f51269dce2fe" 16SRC_URI[sha256sum] = "a3f875b80ec11a452480690108660030978c94fa8e796ad6d943a874b496f1c4"
17 17
18DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc" 18DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc bison-native"
19CFLAGS += "-I${STAGING_INCDIR}/tirpc" 19CFLAGS += "-I${STAGING_INCDIR}/tirpc"
20LDFLAGS += "-ltirpc" 20LDFLAGS += "-ltirpc"
21 21