diff options
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/crda/crda_3.18.bb | 25 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2014.11.18.bb | 18 |
2 files changed, 24 insertions, 19 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_3.18.bb b/meta-networking/recipes-connectivity/crda/crda_3.18.bb index 7e13d7ba7..4a9393058 100644 --- a/meta-networking/recipes-connectivity/crda/crda_3.18.bb +++ b/meta-networking/recipes-connectivity/crda/crda_3.18.bb | |||
@@ -1,23 +1,18 @@ | |||
1 | SUMMARY = "Wireless Central Regulatory Domain Agent" | 1 | SUMMARY = "Wireless Central Regulatory Domain Agent" |
2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" | 2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" |
3 | SECTION = "net" | 3 | SECTION = "net" |
4 | LICENSE = "copyleft-next-0.3.0 & ISC" | 4 | LICENSE = "copyleft-next-0.3.0" |
5 | LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe \ | 5 | LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe" |
6 | file://${WORKDIR}/wireless-regdb-2014.11.18/LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c" | ||
7 | 6 | ||
8 | DEPENDS = "python-m2crypto-native python-native libgcrypt libnl" | 7 | DEPENDS = "python-m2crypto-native python-native libgcrypt libnl" |
9 | 8 | ||
10 | SRC_URI = "https://www.kernel.org/pub/software/network/crda/${BP}.tar.xz;name=crda \ | 9 | SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \ |
11 | https://www.kernel.org/pub/software/network/wireless-regdb/wireless-regdb-2014.11.18.tar.xz;name=bin \ | ||
12 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ | 10 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ |
13 | file://fix-linking-of-libraries-used-by-reglib.patch \ | 11 | file://fix-linking-of-libraries-used-by-reglib.patch \ |
14 | file://fix-gcc-6-unused-variables.patch \ | 12 | file://fix-gcc-6-unused-variables.patch \ |
15 | " | 13 | " |
16 | SRC_URI[crda.md5sum] = "0431fef3067bf503dfb464069f06163a" | 14 | SRC_URI[md5sum] = "0431fef3067bf503dfb464069f06163a" |
17 | SRC_URI[crda.sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" | 15 | SRC_URI[sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" |
18 | |||
19 | SRC_URI[bin.md5sum] = "d750c402c5510add7380edcb1d9b75b2" | ||
20 | SRC_URI[bin.sha256sum] = "eab6b50f30748a8b0065ba38cf3df05aac161a5861ae0a6c3cfd01d38a71c9dd" | ||
21 | 16 | ||
22 | inherit python-dir pythonnative | 17 | inherit python-dir pythonnative |
23 | # Recursive make problem | 18 | # Recursive make problem |
@@ -29,14 +24,6 @@ do_compile() { | |||
29 | 24 | ||
30 | do_install() { | 25 | do_install() { |
31 | oe_runmake SBINDIR=${sbindir}/ install | 26 | oe_runmake SBINDIR=${sbindir}/ install |
32 | |||
33 | install -d ${D}${libdir}/crda/ | ||
34 | |||
35 | install -m 0644 ${WORKDIR}/wireless-regdb-2014.11.18/regulatory.bin ${D}${libdir}/crda/regulatory.bin | ||
36 | } | 27 | } |
37 | 28 | ||
38 | 29 | RDEPENDS_${PN} = "udev wireless-regdb" | |
39 | RDEPENDS_${PN} = "udev" | ||
40 | FILES_${PN} += "${libdir}crda/regulatory.bin \ | ||
41 | ${base_libdir}/udev/rules.d/85-regulatory.rules \ | ||
42 | " | ||
diff --git a/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2014.11.18.bb b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2014.11.18.bb new file mode 100644 index 000000000..b3d82ba1c --- /dev/null +++ b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2014.11.18.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Wireless Central Regulatory Domain Database" | ||
2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" | ||
3 | SECTION = "net" | ||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c" | ||
6 | |||
7 | SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz" | ||
8 | SRC_URI[md5sum] = "d750c402c5510add7380edcb1d9b75b2" | ||
9 | SRC_URI[sha256sum] = "eab6b50f30748a8b0065ba38cf3df05aac161a5861ae0a6c3cfd01d38a71c9dd" | ||
10 | |||
11 | inherit bin_package | ||
12 | |||
13 | do_install() { | ||
14 | install -d -m0755 ${D}${libdir}/crda | ||
15 | install -m 0644 regulatory.bin ${D}${libdir}/crda/regulatory.bin | ||
16 | } | ||
17 | |||
18 | RSUGGESTS_${PN} = "crda" | ||