summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch36
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch b/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch
new file mode 100644
index 0000000000..1712a53462
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch
@@ -0,0 +1,36 @@
1From ebe9144fdfdc8154661b93322cec4a1c43aa75ff Mon Sep 17 00:00:00 2001
2From: alperak <alperyasinak1@gmail.com>
3Date: Tue, 1 Oct 2024 19:45:38 +0300
4Subject: [PATCH] Fix invalid conversion from int to CURLoption
5
6Options.hpp:281:74: error: invalid conversion from 'int' to 'CURLoption' [-fpermissive]
7 281 | typedef curlpp::OptionTrait<curl_closepolicy, CURLOPT_CLOSEPOLICY> ClosePolicy;
8 | ^
9 | |
10 | int
11
12Fix invalid conversion by adding explicit cast to CURLoption
13
14Upstream-Status: Pending
15
16Signed-off-by: alperak <alperyasinak1@gmail.com>
17---
18 include/curlpp/Options.hpp | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/include/curlpp/Options.hpp b/include/curlpp/Options.hpp
22index c705c9d..7c9a501 100644
23--- a/include/curlpp/Options.hpp
24+++ b/include/curlpp/Options.hpp
25@@ -278,7 +278,7 @@ namespace options
26 typedef curlpp::OptionTrait<long, CURLOPT_LOW_SPEED_LIMIT> LowSpeedLimit;
27 typedef curlpp::OptionTrait<long, CURLOPT_LOW_SPEED_TIME> LowSpeedTime;
28 typedef curlpp::OptionTrait<long, CURLOPT_MAXCONNECTS> MaxConnects;
29- typedef curlpp::OptionTrait<curl_closepolicy, CURLOPT_CLOSEPOLICY> ClosePolicy;
30+ typedef curlpp::OptionTrait<curl_closepolicy, (CURLoption)CURLOPT_CLOSEPOLICY> ClosePolicy;
31 typedef curlpp::OptionTrait<bool, CURLOPT_FRESH_CONNECT> FreshConnect;
32 typedef curlpp::OptionTrait<bool, CURLOPT_FORBID_REUSE> ForbidReuse;
33 typedef curlpp::OptionTrait<long, CURLOPT_CONNECTTIMEOUT> ConnectTimeout;
34--
352.25.1
36
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 131f1873a2..cacdc9773b 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -8,7 +8,8 @@ DEPENDS = "curl"
8DEPENDS:class-native = "curl-native" 8DEPENDS:class-native = "curl-native"
9 9
10SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \ 10SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \
11 file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch" 11 file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch \
12 file://0002-fix-invalid-conversion-from-int-to-CURLoption.patch"
12 13
13SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f" 14SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
14 15