summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-keytools.c-Don-t-check-for-return-from-EVP_M.patch33
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-keytools.c-Don-t-check-for-return-from-EVP_M.patch b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-keytools.c-Don-t-check-for-return-from-EVP_M.patch
new file mode 100644
index 000000000..af242fafb
--- /dev/null
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-keytools.c-Don-t-check-for-return-from-EVP_M.patch
@@ -0,0 +1,33 @@
1From d3027a227bc0f603a5b650d01f97ee1dec515be5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 18 Sep 2015 00:28:45 -0400
4Subject: [PATCH] snmplib/keytools.c: Don't check for return from
5 EVP_MD_CTX_init()
6
7EVP_MD_CTX_init() API returns void, it fixes errors with new compilers
8
9snmplib/keytools.c: In function 'generate_Ku': error: invalid use of void expression
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13Upstream-Status: Submitted [https://sourceforge.net/p/net-snmp/patches/1317/]
14 snmplib/keytools.c | 3 +--
15 1 file changed, 1 insertion(+), 2 deletions(-)
16
17diff --git a/snmplib/keytools.c b/snmplib/keytools.c
18index 0ccb3a6..880fc14 100644
19--- a/snmplib/keytools.c
20+++ b/snmplib/keytools.c
21@@ -153,8 +153,7 @@ generate_Ku(const oid * hashtype, u_int hashtype_len,
22 ctx = EVP_MD_CTX_create();
23 #else
24 ctx = malloc(sizeof(*ctx));
25- if (!EVP_MD_CTX_init(ctx))
26- return SNMPERR_GENERR;
27+ EVP_MD_CTX_init(ctx);
28 #endif
29 #ifndef NETSNMP_DISABLE_MD5
30 if (ISTRANSFORM(hashtype, HMACMD5Auth)) {
31--
322.5.2
33
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index 431a6330f..b32d842de 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -20,6 +20,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.zip \
20 file://run-ptest \ 20 file://run-ptest \
21 file://dont-return-incompletely-parsed-varbinds.patch \ 21 file://dont-return-incompletely-parsed-varbinds.patch \
22 file://0001-config_os_headers-Error-Fix.patch \ 22 file://0001-config_os_headers-Error-Fix.patch \
23 file://0001-snmplib-keytools.c-Don-t-check-for-return-from-EVP_M.patch \
23" 24"
24SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee" 25SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee"
25SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e" 26SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e"