diff options
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/tunctl/tunctl.inc | 4 | ||||
-rw-r--r-- | meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch | 19 |
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/tunctl/tunctl.inc b/meta-networking/recipes-support/tunctl/tunctl.inc index e95cfa523..1c11823dd 100644 --- a/meta-networking/recipes-support/tunctl/tunctl.inc +++ b/meta-networking/recipes-support/tunctl/tunctl.inc | |||
@@ -3,7 +3,9 @@ SECTION = "net" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://tunctl.c;beginline=1;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999" | 4 | LIC_FILES_CHKSUM = "file://tunctl.c;beginline=1;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999" |
5 | 5 | ||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz" | 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz \ |
7 | file://makefile-add-ldflags.patch \ | ||
8 | " | ||
7 | 9 | ||
8 | do_compile() { | 10 | do_compile() { |
9 | oe_runmake tunctl | 11 | oe_runmake tunctl |
diff --git a/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch new file mode 100644 index 000000000..c96f538d2 --- /dev/null +++ b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed. | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
6 | |||
7 | diff --git a/Makefile b/Makefile | ||
8 | index a0aa7f6..d6ce2c7 100644 | ||
9 | --- a/Makefile | ||
10 | +++ b/Makefile | ||
11 | @@ -14,7 +14,7 @@ MAN_DIR ?= /usr/share/man/man$(MANS) | ||
12 | all : $(BIN) $(MAN) | ||
13 | |||
14 | $(BIN) : $(BIN).c | ||
15 | - $(CC) $(CFLAGS) -o $(BIN) $(BIN).c | ||
16 | + $(CC) $(CFLAGS) ${LDFLAGS} -o $(BIN) $(BIN).c | ||
17 | |||
18 | $(MAN) : $(PACKAGE).sgml | ||
19 | docbook2man $(PACKAGE).sgml | ||