diff options
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/libtdb/libtdb/tdb-Add-configure-options-for-packages.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-support/libtdb/libtdb_1.3.14.bb (renamed from meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb) | 4 |
2 files changed, 27 insertions, 20 deletions
diff --git a/meta-networking/recipes-support/libtdb/libtdb/tdb-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libtdb/libtdb/tdb-Add-configure-options-for-packages.patch index 400055773..272921e56 100644 --- a/meta-networking/recipes-support/libtdb/libtdb/tdb-Add-configure-options-for-packages.patch +++ b/meta-networking/recipes-support/libtdb/libtdb/tdb-Add-configure-options-for-packages.patch | |||
@@ -1,7 +1,10 @@ | |||
1 | From 10ac5e5fdda44adcc2a159b6f9a2d51a51361057 Mon Sep 17 00:00:00 2001 | 1 | From 24911f36bcb00412e5dc4cd11fda139e09d58798 Mon Sep 17 00:00:00 2001 |
2 | From: Jackie Huang <jackie.huang@windriver.com> | 2 | From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> |
3 | Date: Wed, 21 Sep 2016 10:46:19 +0800 | 3 | Date: Tue, 1 Aug 2017 03:12:09 +0900 |
4 | Subject: [PATCH] tdb: Add configure options for packages | 4 | Subject: [PATCH] From 10ac5e5fdda44adcc2a159b6f9a2d51a51361057 Mon Sep 17 |
5 | 00:00:00 2001 From: Jackie Huang <jackie.huang@windriver.com> Date: Wed, 21 | ||
6 | Sep 2016 10:46:19 +0800 Subject: [PATCH] tdb: Add configure options for | ||
7 | packages | ||
5 | 8 | ||
6 | Add configure options for the following packages: | 9 | Add configure options for the following packages: |
7 | - acl | 10 | - acl |
@@ -14,6 +17,10 @@ Add configure options for the following packages: | |||
14 | Upstream-Status: Inappropriate [oe deterministic build specific] | 17 | Upstream-Status: Inappropriate [oe deterministic build specific] |
15 | 18 | ||
16 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | 19 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> |
20 | |||
21 | Update for libtdb_1.3.14. | ||
22 | |||
23 | Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> | ||
17 | --- | 24 | --- |
18 | lib/replace/system/wscript_configure | 6 ++- | 25 | lib/replace/system/wscript_configure | 6 ++- |
19 | lib/replace/wscript | 85 ++++++++++++++++++++++++++++-------- | 26 | lib/replace/wscript | 85 ++++++++++++++++++++++++++++-------- |
@@ -37,7 +44,7 @@ index 2035474..10f9ae7 100644 | |||
37 | 44 | ||
38 | # solaris varients of getXXent_r | 45 | # solaris varients of getXXent_r |
39 | diff --git a/lib/replace/wscript b/lib/replace/wscript | 46 | diff --git a/lib/replace/wscript b/lib/replace/wscript |
40 | index 145300d..310048c 100644 | 47 | index 7c50e1d..15df5c3 100644 |
41 | --- a/lib/replace/wscript | 48 | --- a/lib/replace/wscript |
42 | +++ b/lib/replace/wscript | 49 | +++ b/lib/replace/wscript |
43 | @@ -23,6 +23,41 @@ def set_options(opt): | 50 | @@ -23,6 +23,41 @@ def set_options(opt): |
@@ -124,7 +131,7 @@ index 145300d..310048c 100644 | |||
124 | conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') | 131 | conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') |
125 | conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') | 132 | conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') |
126 | conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') | 133 | conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') |
127 | @@ -248,17 +298,18 @@ def configure(conf): | 134 | @@ -251,17 +301,18 @@ def configure(conf): |
128 | 135 | ||
129 | conf.CHECK_FUNCS('prctl dirname basename') | 136 | conf.CHECK_FUNCS('prctl dirname basename') |
130 | 137 | ||
@@ -155,23 +162,23 @@ index 145300d..310048c 100644 | |||
155 | conf.CHECK_CODE(''' | 162 | conf.CHECK_CODE(''' |
156 | struct ucred cred; | 163 | struct ucred cred; |
157 | diff --git a/wscript b/wscript | 164 | diff --git a/wscript b/wscript |
158 | index 50b2286..748eef1 100644 | 165 | index 1c9655a..8c20d3b 100644 |
159 | --- a/wscript | 166 | --- a/wscript |
160 | +++ b/wscript | 167 | +++ b/wscript |
161 | @@ -64,7 +64,12 @@ def set_options(opt): | 168 | @@ -62,7 +62,12 @@ def set_options(opt): |
162 | opt.add_option('--disable-python', | 169 | help=("Disable the use of pthread robust mutexes"), |
163 | help=("disable the pytdb module"), | 170 | action="store_true", dest='disable_tdb_mutex_locking', |
164 | action="store_true", dest='disable_python', default=False) | 171 | default=False) |
165 | - | 172 | - |
166 | + opt.add_option('--with-valgrind', | 173 | + opt.add_option('--with-valgrind', |
167 | + help=("enable use of valgrind"), | 174 | + help=("enable use of valgrind"), |
168 | + action="store_true", dest='enable_valgrind') | 175 | + action="store_true", dest='enable_valgrind') |
169 | + opt.add_option('--without-valgrind', | 176 | + opt.add_option('--without-valgrind', |
170 | + help=("disable use of valgrind"), | 177 | + help=("disable use of valgrind"), |
171 | + action="store_false", dest='enable_valgrind', default=False) | 178 | + action="store_false", dest='enable_valgrind', default=False) |
172 | 179 | ||
173 | def configure(conf): | 180 | def configure(conf): |
174 | conf.env.disable_tdb_mutex_locking = getattr(Options.options, | 181 | conf.env.disable_tdb_mutex_locking = getattr(Options.options, |
175 | -- | 182 | -- |
176 | 2.8.3 | 183 | 2.7.4 |
177 | 184 | ||
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb b/meta-networking/recipes-support/libtdb/libtdb_1.3.14.bb index e256ac9b6..ccc4ee43f 100644 --- a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb +++ b/meta-networking/recipes-support/libtdb/libtdb_1.3.14.bb | |||
@@ -10,8 +10,8 @@ SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \ | |||
10 | file://tdb-Add-configure-options-for-packages.patch \ | 10 | file://tdb-Add-configure-options-for-packages.patch \ |
11 | " | 11 | " |
12 | 12 | ||
13 | SRC_URI[md5sum] = "d9627e7aacd535a8251401f914bb6924" | 13 | SRC_URI[md5sum] = "dd23f2ba8ca2bfdcb833bc79d5b5ac6f" |
14 | SRC_URI[sha256sum] = "60134e32253cac8e2efe5e0185d20123c208bcf6ad15edf2f50d80daadf8c348" | 14 | SRC_URI[sha256sum] = "3a7d4bb79229460df530c7e1c7067ba9fb9d370aa61fff537fdc2bdf918acbe9" |
15 | 15 | ||
16 | PACKAGECONFIG ??= "\ | 16 | PACKAGECONFIG ??= "\ |
17 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ | 17 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ |