diff options
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r-- | meta-networking/recipes-support/wireshark/README | 37 | ||||
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb | 41 |
2 files changed, 78 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/README b/meta-networking/recipes-support/wireshark/README new file mode 100644 index 000000000..0e0c52656 --- /dev/null +++ b/meta-networking/recipes-support/wireshark/README | |||
@@ -0,0 +1,37 @@ | |||
1 | # | ||
2 | Wireshark - Notes | ||
3 | |||
4 | URL: http://www.wireshark.org/ | ||
5 | User Guide: http://www.wireshark.org/docs/wsug_html_chunked/ | ||
6 | Secruity advisories: http://www.wireshark.org/security/ | ||
7 | |||
8 | Wireshark is slowly moving away from gtk and towards QT as their graphical stack. | ||
9 | Currently gtk is supported with this release and I plan on integrating QT. | ||
10 | |||
11 | |||
12 | |||
13 | Adding the wireshark to your build | ||
14 | ======================================== | ||
15 | |||
16 | via local.conf | ||
17 | IMAGE_INSTALL_append = " wireshark" | ||
18 | |||
19 | Adding the wireshark to your graphical build | ||
20 | ======================================== | ||
21 | via local.conf | ||
22 | EXTRA_IMAGE_FEATURES += "x11-base" | ||
23 | |||
24 | or use the "core-image-x11" | ||
25 | |||
26 | |||
27 | Maintenance | ||
28 | ----------- | ||
29 | |||
30 | Send patches, comments or questions to openembedded-devel@lists.openembedded.org | ||
31 | |||
32 | When sending single patches, please using something like: | ||
33 | 'git send-email -1 --to openembedded-devel@lists.openembedded.org --cc akuster@mvista.com --subject-prefix=meta-security][PATCH' | ||
34 | |||
35 | Maintainer: Armin Kuster <akuster@mvista.com> | ||
36 | |||
37 | |||
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb new file mode 100644 index 000000000..554223124 --- /dev/null +++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "wireshark - a popular network protocol analyzer" | ||
2 | HOMEPAGE = "http://www.wireshark.org" | ||
3 | SECTION = "network" | ||
4 | LICENSE = "GPL-2.0" | ||
5 | |||
6 | DEPENDS = "perl-native libpcap pcre expat glib-2.0 libsmi" | ||
7 | |||
8 | inherit autotools | ||
9 | |||
10 | ARM_INSTRUCTION_SET = "arm" | ||
11 | |||
12 | # Works with either gtk+ or gtk3. | ||
13 | WHICH_GTK = "gtk3" | ||
14 | |||
15 | PACKAGECONFIG ??= "gnutls gcrypt" | ||
16 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}" | ||
17 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" | ||
18 | |||
19 | PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+" | ||
20 | PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3" | ||
21 | PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark," | ||
22 | PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6," | ||
23 | PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls" | ||
24 | PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt" | ||
25 | |||
26 | EXTRA_OECONF = "--with-qt=no --enable-usr-local=no -enable-tshark" | ||
27 | |||
28 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" | ||
29 | SRC_URI = "http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-1.12.0-rc2.tar.bz2 " | ||
30 | |||
31 | SRC_URI[md5sum] = "dc1149073066a29f91116c168558262e" | ||
32 | SRC_URI[sha256sum]= "31009bb450126e9b12808267419f31016d14e6fde7b5e39c85ad37459908cffb" | ||
33 | |||
34 | do_configure_prepend() { | ||
35 | # force to use fallback | ||
36 | sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags | ||
37 | } | ||
38 | |||
39 | ALLOW_EMPTY_${PN} = "1" | ||
40 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
41 | |||