summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
new file mode 100644
index 000000000..76cb30a91
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "perl-native pcre expat glib-2.0 sbc"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11SRC_URI[md5sum] = "62dc20f5a77542feed2e38f18db8ae3b"
12SRC_URI[sha256sum] = "e196376e75fe21fdef41b4eaa27ce2e1b2b561e7f7b20328a8e96657cc4465fc"
13
14PE = "1"
15
16inherit autotools pkgconfig
17
18ARM_INSTRUCTION_SET = "arm"
19
20# Works with either gtk+ or gtk3.
21WHICH_GTK = "gtk+"
22
23PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
24PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
25PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
26#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
27
28PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
29PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
30PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
31PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
32PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
33PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
34PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
35PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
36PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
37PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
38PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
39PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
40PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
41PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
42PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
43PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
44PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
45
46# these next two options require addional layers
47PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
48PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
49
50EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --enable-rawshark"
51
52do_configure_prepend() {
53 # force to use fallback
54 sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
55}
56
57ALLOW_EMPTY_${PN} = "1"
58INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
59
60FILES_${PN} += "${datadir}*"