summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb')
-rw-r--r--meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb b/meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb
new file mode 100644
index 000000000..c1ad203bc
--- /dev/null
+++ b/meta-networking/recipes-support/traceroute/traceroute_2.1.3.bb
@@ -0,0 +1,46 @@
1SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0+ & LGPL-2.1+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
16UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/traceroute/"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
19 file://filter-out-the-patches-from-subdirs.patch \
20"
21
22SRC_URI[sha256sum] = "05ebc7aba28a9100f9bbae54ceecbf75c82ccf46bdfce8b5d64806459a7e0412"
23
24EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
25
26do_compile() {
27 export LDFLAGS="${TARGET_LDFLAGS} -L${S}/libsupp"
28 oe_runmake "env=yes"
29}
30
31do_install() {
32 install -d ${D}${bindir}
33 install -m755 ${BPN}/${BPN} ${D}${bindir}
34
35 install -m755 wrappers/tcptraceroute ${D}${bindir}
36
37 install -d ${D}${mandir}/man8
38 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}/man8
39 ln -s ${BPN}.8 ${D}${mandir}/man8/${BPN}6.8
40 ln -s ${BPN}.8 ${D}${mandir}/man8/tcptraceroute.8
41
42}
43
44ALTERNATIVE_PRIORITY = "60"
45ALTERNATIVE_${PN} = "traceroute"
46ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"