summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tnftp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/tnftp')
-rw-r--r--meta-networking/recipes-support/tnftp/tnftp/tnftp-autotools.patch42
-rw-r--r--meta-networking/recipes-support/tnftp/tnftp_20130505.bb36
2 files changed, 78 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tnftp/tnftp/tnftp-autotools.patch b/meta-networking/recipes-support/tnftp/tnftp/tnftp-autotools.patch
new file mode 100644
index 000000000..1bda576bc
--- /dev/null
+++ b/meta-networking/recipes-support/tnftp/tnftp/tnftp-autotools.patch
@@ -0,0 +1,42 @@
1[PATCH] Update configure.ac and Makefile.am to resolve warnings/errors
2
3Upstream-Status: Pending
4
5Signed-off-by: Roy Li <rongqing.li@windriver.com>
6---
7 configure.ac | 2 ++
8 libnetbsd/Makefile.am | 2 +-
9 2 files changed, 3 insertions(+), 1 deletion(-)
10
11diff --git a/configure.ac b/configure.ac
12index a96d2ab..b3b3069 100644
13--- a/configure.ac
14+++ b/configure.ac
15@@ -71,9 +71,11 @@ AH_TEMPLATE([WITH_SSL],
16 #
17 # Checks for programs.
18 #
19+AM_PROG_AR()
20 AC_PROG_CC()
21 AC_PROG_AWK()
22 AC_PROG_LIBTOOL()
23+AM_PROG_CC_C_O()
24
25 #
26 # Checks for tool features.
27diff --git a/libnetbsd/Makefile.am b/libnetbsd/Makefile.am
28index 3e5c3ce..39bb12d 100644
29--- a/libnetbsd/Makefile.am
30+++ b/libnetbsd/Makefile.am
31@@ -5,7 +5,7 @@ noinst_LTLIBRARIES = libnetbsd.la
32 libnetbsd_la_SOURCES =
33
34
35-CPPFLAGS = \
36+AM_CPPFLAGS = \
37 -I$(srcdir) \
38 -I$(top_srcdir) \
39 -I$(top_builddir)
40--
411.7.10.4
42
diff --git a/meta-networking/recipes-support/tnftp/tnftp_20130505.bb b/meta-networking/recipes-support/tnftp/tnftp_20130505.bb
new file mode 100644
index 000000000..eda9d5c0f
--- /dev/null
+++ b/meta-networking/recipes-support/tnftp/tnftp_20130505.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Enhanced NetBSD ftp client"
2DESCRIPTION = "tnftp (formerly known as lukemftp) is a port of the NetBSD FTP client \
3to other systems. It offers many enhancements over the traditional \
4BSD FTP client, including command-line editing, command-line fetches \
5of FTP and HTTP URLs (including via proxies), command-line uploads of \
6FTP URLs, context-sensitive word completion, dynamic progress bar, \
7IPv6 support, modification time preservation, paging of local and \
8remote files, passive mode support (with fallback to active mode), \
9SOCKS support, TIS FWTK gate-ftp server support, and transfer rate \
10throttling."
11
12SECTION = "console/network"
13LICENSE = "BSD-4-Clause"
14
15DEPENDS = "ncurses"
16
17SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/${BPN}-${PV}.tar.gz \
18 file://tnftp-autotools.patch \
19 "
20
21inherit autotools update-alternatives pkgconfig
22
23ALTERNATIVE_PRIORITY = "100"
24
25ALTERNATIVE_${PN} = "ftp"
26ALTERNATIVE_LINK_NAME_${PN} = "${bindir}/ftp"
27ALTERNATIVE_TARGET_${PN} = "${bindir}/tnftp"
28
29FILES_${PN} = "${bindir}/tnftp"
30
31LIC_FILES_CHKSUM = "file://COPYING;md5=6d6796cb166a9bb050958241dad9479e"
32SRC_URI[md5sum] = "66e218d02ec7d9fc39ab70ba2900305a"
33SRC_URI[sha256sum] = "6f650e25f6fd51538f677b789b49379f367ae9f1dee74c94cfe24d92abc2cffb"
34
35PACKAGECONFIG ?= "openssl"
36PACKAGECONFIG[openssl] = "--enable-ssl, --disable-ssl --with-ssl=no, openssl"