summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb')
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
new file mode 100644
index 000000000..1fb722a44
--- /dev/null
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
@@ -0,0 +1,33 @@
1SUMMARY = "A full-featured SSL VPN solution via tun device."
2HOMEPAGE = "http://openvpn.sourceforge.net"
3SECTION = "console/network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5aac200199fde47501876cba7263cb0c"
6DEPENDS = "lzo openssl iproute2 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
7
8inherit autotools
9
10SRC_URI = "http://swupdate.openvpn.org/community/releases/openvpn-${PV}.tar.gz \
11 file://openvpn"
12
13SRC_URI[md5sum] = "04d47237907faabe9d046970ffe44b2e"
14SRC_URI[sha256sum] = "af506d5f48568fa8d2f2435cb3fad35f9a9a8f263999ea6df3ba296960cec85a"
15
16CFLAGS += "-fno-inline"
17
18# I want openvpn to be able to read password from file (hrw)
19EXTRA_OECONF += "--enable-password-save --enable-iproute2"
20EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-plugin-auth-pam', d)}"
21
22# Explicitly specify IPROUTE to bypass the configure-time check for /sbin/ip on the host.
23EXTRA_OECONF += "IPROUTE=/sbin/ip"
24
25do_install_append() {
26 install -d ${D}/${sysconfdir}/init.d
27 install -d ${D}/${sysconfdir}/openvpn
28 install -m 755 ${WORKDIR}/openvpn ${D}/${sysconfdir}/init.d
29}
30
31RRECOMMENDS_${PN} = "kernel-module-tun"
32
33FILES_${PN}-dbg += "${libdir}/openvpn/plugins/.debug"