summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb157
1 files changed, 157 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb
new file mode 100644
index 000000000..fba2f5ed1
--- /dev/null
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p7.bb
@@ -0,0 +1,157 @@
1SUMMARY = "Network Time Protocol daemon and utilities"
2DESCRIPTION = "The Network Time Protocol (NTP) is used to \
3synchronize the time of a computer client or server to \
4another server or reference time source, such as a radio \
5or satellite receiver or modem."
6HOMEPAGE = "http://support.ntp.org"
7SECTION = "net"
8LICENSE = "NTP"
9LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f41fedb22dffefcbfafecc85b0f79cfa"
10
11DEPENDS = "libevent"
12
13SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
14 file://ntp-4.2.4_p6-nano.patch \
15 file://ntpd \
16 file://ntp.conf \
17 file://ntpdate \
18 file://ntpdate.default \
19 file://ntpdate.service \
20 file://ntpd.service \
21 file://sntp.service \
22 file://sntp \
23 file://ntpd.list \
24"
25
26SRC_URI[md5sum] = "46dfba933c3e4bc924d8e55068797578"
27SRC_URI[sha256sum] = "81d20c06a0b01abe3b84fac092185bf014252d38fe5e7b2758f604680a0220dc"
28
29inherit autotools update-rc.d useradd systemd pkgconfig
30
31# The ac_cv_header_readline_history is to stop ntpdc depending on either
32# readline or curses
33EXTRA_OECONF += "--with-net-snmp-config=no \
34 --without-ntpsnmpd \
35 ac_cv_header_readline_history_h=no \
36 --with-yielding_select=yes \
37 --with-locfile=redhat \
38 --without-rpath \
39 "
40CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
41
42USERADD_PACKAGES = "${PN}"
43NTP_USER_HOME ?= "/var/lib/ntp"
44USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \
45 --no-create-home \
46 --shell /bin/false --user-group ntp"
47
48# NB: debug is default-enabled by NTP; keep it default-enabled here.
49PACKAGECONFIG ??= "cap debug refclocks"
50PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
51 --with-openssl-incdir=${STAGING_INCDIR} \
52 --with-crypto, \
53 --without-openssl --without-crypto, \
54 openssl"
55PACKAGECONFIG[cap] = "--enable-linuxcaps,--disable-linuxcaps,libcap"
56PACKAGECONFIG[readline] = "--with-lineeditlibs,--without-lineeditlibs,readline"
57PACKAGECONFIG[refclocks] = "--enable-all-clocks,--disable-all-clocks,pps-tools"
58PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
59
60do_install_append() {
61 install -d ${D}${sysconfdir}/init.d
62 install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir}
63 install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d
64 install -d ${D}${bindir}
65 install -m 755 ${WORKDIR}/ntpdate ${D}${bindir}/ntpdate-sync
66
67 install -m 755 -d ${D}${NTP_USER_HOME}
68 chown ntp:ntp ${D}${NTP_USER_HOME}
69
70 # Fix hardcoded paths in scripts
71 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
72 sed -i 's!/usr/bin/!${bindir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
73 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
74 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
75 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${bindir}/ntpdate-sync
76 sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/ntptrace
77 sed -i '/use/i use warnings;' ${D}${sbindir}/ntptrace
78 sed -i '1s,#!.*perl,#! ${bindir}/env perl,' ${D}${sbindir}/ntp-wait
79 sed -i '/use/i use warnings;' ${D}${sbindir}/ntp-wait
80 sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/calc_tickadj
81 sed -i '/use/i use warnings;' ${D}${sbindir}/calc_tickadj
82
83 install -d ${D}/${sysconfdir}/default
84 install -m 644 ${WORKDIR}/ntpdate.default ${D}${sysconfdir}/default/ntpdate
85 install -m 0644 ${WORKDIR}/sntp ${D}${sysconfdir}/default/
86
87 install -d ${D}/${sysconfdir}/network/if-up.d
88 ln -s ${bindir}/ntpdate-sync ${D}/${sysconfdir}/network/if-up.d
89
90 install -d ${D}${systemd_unitdir}/system
91 install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
92 install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
93 install -m 0644 ${WORKDIR}/sntp.service ${D}${systemd_unitdir}/system/
94
95 install -d ${D}${systemd_unitdir}/ntp-units.d
96 install -m 0644 ${WORKDIR}/ntpd.list ${D}${systemd_unitdir}/ntp-units.d/60-ntpd.list
97}
98
99PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils"
100# NOTE: you don't need ntpdate, use "ntpd -q -g -x"
101
102# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
103# with wonky clocks (e.g. OpenSlug)
104RDEPENDS_${PN} = "${PN}-tickadj"
105# Handle move from bin to utils package
106RPROVIDES_${PN}-utils = "${PN}-bin"
107RREPLACES_${PN}-utils = "${PN}-bin"
108RCONFLICTS_${PN}-utils = "${PN}-bin"
109
110SYSTEMD_PACKAGES = "${PN} ntpdate sntp"
111SYSTEMD_SERVICE_${PN} = "ntpd.service"
112SYSTEMD_SERVICE_ntpdate = "ntpdate.service"
113SYSTEMD_SERVICE_sntp = "sntp.service"
114
115RPROVIDES_${PN} += "${PN}-systemd"
116RREPLACES_${PN} += "${PN}-systemd"
117RCONFLICTS_${PN} += "${PN}-systemd"
118
119RPROVIDES_ntpdate += "ntpdate-systemd"
120RREPLACES_ntpdate += "ntpdate-systemd"
121RCONFLICTS_ntpdate += "ntpdate-systemd"
122
123RSUGGESTS_${PN} = "iana-etc"
124
125FILES_${PN} = "${sbindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \
126 ${NTP_USER_HOME} \
127 ${systemd_unitdir}/ntp-units.d/60-ntpd.list ${libexecdir}\
128"
129FILES_${PN}-tickadj = "${sbindir}/tickadj"
130FILES_${PN}-utils = "${sbindir} ${datadir}/ntp/lib"
131RDEPENDS_${PN}-utils += "perl"
132FILES_ntpdate = "${sbindir}/ntpdate \
133 ${sysconfdir}/network/if-up.d/ntpdate-sync \
134 ${bindir}/ntpdate-sync \
135 ${sysconfdir}/default/ntpdate \
136 ${systemd_unitdir}/system/ntpdate.service \
137"
138FILES_sntp = "${sbindir}/sntp \
139 ${sysconfdir}/default/sntp \
140 ${systemd_unitdir}/system/sntp.service \
141 "
142
143CONFFILES_${PN} = "${sysconfdir}/ntp.conf"
144CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate"
145
146INITSCRIPT_NAME = "ntpd"
147# No dependencies, so just go in at the standard level (20)
148INITSCRIPT_PARAMS = "defaults"
149
150pkg_postinst_ntpdate() {
151 if ! grep -q -s ntpdate $D/var/spool/cron/root; then
152 echo "adding crontab"
153 test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron
154 echo "30 * * * * ${bindir}/ntpdate-sync silent" >> $D/var/spool/cron/root
155 fi
156}
157