summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/nis.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/nis/nis.inc')
-rw-r--r--meta-networking/recipes-support/nis/nis.inc31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/nis.inc b/meta-networking/recipes-support/nis/nis.inc
new file mode 100644
index 000000000..f9f5bd1b4
--- /dev/null
+++ b/meta-networking/recipes-support/nis/nis.inc
@@ -0,0 +1,31 @@
1# This include file contains global definitions for the
2# various NIS packages.
3#
4# These packages will only function correctly with glibc -
5# the rpcsvc functionality is not present in uclibc
6DESCRIPTION = "NIS Server and Tools"
7HOMEPAGE = "http://www.linux-nis.org/nis/"
8SECTION = "console/network"
9LICENSE = "GPL-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
11
12inherit autotools gettext
13
14# install is broken because src/Makefile heroically adds '-s'
15# to the install flags - passing -s to the build /usr/bin/install!
16# install-strip gets it right but installs ypbind -m <default>,
17# not -m 555. In an OE build this is not, so far as I can see,
18# a security problem (and this fix to the build problem is *much*
19# easier and more maintainable.)
20do_install() {
21 oe_runmake 'DESTDIR=${D}' install-strip
22}
23
24# An attempt to build on uclibc will fail, causing annoyance,
25# so force the package to be skipped here (this will cause a
26# 'nothing provides' error)
27python () {
28 os = bb.data.getVar("TARGET_OS", d, 1)
29 if os == "linux-uclibc":
30 raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
31}