summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf/netcf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/netcf/netcf_git.bb')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 26c738b2c..08082ffb4 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -16,13 +16,33 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit gettext autotools-bootstrap pkgconfig systemd 19inherit gettext autotools pkgconfig systemd
20 20
21EXTRA_OECONF_append_class-target = " --with-driver=redhat" 21EXTRA_OECONF_append_class-target = " --with-driver=redhat"
22 22
23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" 23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}"
24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts," 24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts,"
25 25
26do_configure_prepend() {
27 currdir=`pwd`
28 cd ${S}
29
30 # avoid bootstrap cloning gnulib on every configure
31 cat >.gitmodules <<EOF
32[submodule "gnulib"]
33 path = gnulib
34 url = git://git.sv.gnu.org/gnulib
35EOF
36 cp -rf ${STAGING_DATADIR}/gnulib ${S}
37
38 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
39 # | bootstrap: running: libtoolize --quiet
40 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
41 # | ...
42 ./bootstrap --force
43 cd $currdir
44}
45
26do_install_append() { 46do_install_append() {
27 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 47 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
28 install -d ${D}${systemd_unitdir}/system 48 install -d ${D}${systemd_unitdir}/system