summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf/netcf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/netcf/netcf_git.bb')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 8a8963e44..26c738b2c 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -16,19 +16,13 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit gettext autotools-brokensep pkgconfig systemd 19inherit gettext autotools-bootstrap pkgconfig systemd
20 20
21EXTRA_OECONF_append_class-target = " --with-driver=redhat" 21EXTRA_OECONF_append_class-target = " --with-driver=redhat"
22 22
23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" 23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}"
24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts," 24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts,"
25 25
26do_configure_prepend() {
27 cd ${S}
28 rm -f .gitmodules
29 ./bootstrap --gnulib-srcdir=${STAGING_DATADIR}/gnulib
30}
31
32do_install_append() { 26do_install_append() {
33 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 27 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
34 install -d ${D}${systemd_unitdir}/system 28 install -d ${D}${systemd_unitdir}/system