summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcat/netcat
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/netcat/netcat')
-rw-r--r--meta-networking/recipes-support/netcat/netcat/make-netcat_flag_count_work.patch34
-rw-r--r--meta-networking/recipes-support/netcat/netcat/netcat-locale_h.patch25
-rw-r--r--meta-networking/recipes-support/netcat/netcat/obsolete_autoconf_macros.patch32
3 files changed, 91 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat/make-netcat_flag_count_work.patch b/meta-networking/recipes-support/netcat/netcat/make-netcat_flag_count_work.patch
new file mode 100644
index 000000000..dd1938a99
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat/make-netcat_flag_count_work.patch
@@ -0,0 +1,34 @@
1Make netcat_flag_count() return positive value
2
3C language has 3 distinct char types:
4 char
5 unsigned char
6 signed char
7A char has the same range of values as signed char on X86,
8but same as unsigned char on PPC which made netcat_flag_count
9return a negative value, now we force variable c as signed char
10to make netcat_flag_count return positive value.
11
12Upstream-Status: Pending
13
14Signed-off-by: Roy.Li <rongqing.li@windriver.com>
15---
16 src/flagset.c | 2 +-
17 1 files changed, 1 insertions(+), 1 deletions(-)
18
19diff --git a/src/flagset.c b/src/flagset.c
20index 442b634..54ac898 100644
21--- a/src/flagset.c
22+++ b/src/flagset.c
23@@ -134,7 +134,7 @@ unsigned short netcat_flag_next(unsigned short port)
24
25 int netcat_flag_count(void)
26 {
27- register char c;
28+ register signed char c;
29 register int i;
30 int ret = 0;
31
32--
331.7.5.4
34
diff --git a/meta-networking/recipes-support/netcat/netcat/netcat-locale_h.patch b/meta-networking/recipes-support/netcat/netcat/netcat-locale_h.patch
new file mode 100644
index 000000000..5cbcb08e8
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat/netcat-locale_h.patch
@@ -0,0 +1,25 @@
1Apparently somewhere along the line HAVE_LOCALE_H was changed to
2HAVE_LC_MESSAGES. Adjust netcat to match.
3
4Upstream-Status: Pending
5
6Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
7
8Index: netcat-0.7.1/src/intl.h
9===================================================================
10--- netcat-0.7.1.orig/src/intl.h
11+++ netcat-0.7.1/src/intl.h
12@@ -25,11 +25,11 @@
13 #ifdef ENABLE_NLS
14 #include <libintl.h>
15
16-#ifdef HAVE_LOCALE_H
17+#if defined(HAVE_LC_MESSAGES) || defined(HAVE_LOCALE_H)
18 #include <locale.h>
19 #else
20 #error You must have locale.h in your system
21-#endif /* HAVE_LOCALE_H */
22+#endif /* HAVE_LC_MESSAGES || HAVE_LOCALE_H */
23
24 /* Our dear (and very common) gettext macros */
25 #define _(String) gettext(String)
diff --git a/meta-networking/recipes-support/netcat/netcat/obsolete_autoconf_macros.patch b/meta-networking/recipes-support/netcat/netcat/obsolete_autoconf_macros.patch
new file mode 100644
index 000000000..9b0ed58d6
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat/obsolete_autoconf_macros.patch
@@ -0,0 +1,32 @@
1Replace obsoleted AM_CONFIG_HEADER flagged by autoconf 2.69
2locale.h check was picked from old gettext macros but with new aclocal
3it picks the right 0.18 gettext.m4 and does not get the check
4therefore we explicitly add it to configure.ac
5
6Upstream-Status: Pending
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9
10Index: netcat-0.7.1/configure.ac
11===================================================================
12--- netcat-0.7.1.orig/configure.ac 2013-01-18 01:30:01.928069739 -0800
13+++ netcat-0.7.1/configure.ac 2013-01-18 01:32:50.568073009 -0800
14@@ -26,8 +26,7 @@
15 AC_PREREQ(2.53)
16
17 dnl without this order in this file, automake will be confused!
18-AM_CONFIG_HEADER(config.h)
19-
20+AC_CONFIG_HEADERS(config.h)
21 dnl check for programs. first the c compiler.
22 AC_PROG_CC
23 AC_PROG_CPP
24@@ -56,7 +55,7 @@
25 AC_LBL_LIBRARY_NET
26
27 dnl Fortunately we have Solaris...
28-AC_CHECK_HEADERS(sys/sockio.h)
29+AC_CHECK_HEADERS(sys/sockio.h locale.h)
30
31 AC_CHECK_FUNCS(srandom random)
32 if test $ac_cv_func_srandom = no; then