summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb')
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
new file mode 100644
index 000000000..4237dc4c5
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
@@ -0,0 +1,40 @@
1require netcat.inc
2SUMMARY = "OpenBSD Netcat"
3HOMEPAGE = "http://ftp.debian.org"
4LICENSE = "BSD-3-Clause"
5
6DEPENDS += "glib-2.0 libbsd"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz;name=netcat \
9 ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz;name=netcat-patch"
10
11SRC_URI[netcat.md5sum] = "7e67b22f1ad41a1b7effbb59ff28fca1"
12SRC_URI[netcat.sha256sum] = "40653fe66c1516876b61b07e093d826e2a5463c5d994f1b7e6ce328f3edb211e"
13SRC_URI[netcat-patch.md5sum] = "e914f8eb7eda5c75c679dd77787ac76b"
14SRC_URI[netcat-patch.sha256sum] = "eee759327ffea293e81d0dde67921b7fcfcad279ffd7a2c9d037bbc8f882b363"
15
16S = "${WORKDIR}/${BPN}-${PV}"
17
18do_configure[noexec] = "1"
19
20netcat_do_patch() {
21 cd ${S}
22 while read line; do patch -p1 < ${WORKDIR}/debian/patches/$line; done < ${WORKDIR}/debian/patches/series
23}
24
25python do_patch() {
26 bb.build.exec_func('netcat_do_patch', d)
27 bb.build.exec_func('patch_do_patch', d)
28}
29
30do_compile() {
31 cd ${S}
32 pkgrel=4
33 oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
34}
35
36do_install() {
37 install -d ${D}${bindir}
38 install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
39}
40ALTERNATIVE_PRIORITY = "50"