summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ndisc6/ndisc6_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/ndisc6/ndisc6_git.bb')
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6_git.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_git.bb b/meta-networking/recipes-support/ndisc6/ndisc6_git.bb
new file mode 100644
index 000000000..002303c96
--- /dev/null
+++ b/meta-networking/recipes-support/ndisc6/ndisc6_git.bb
@@ -0,0 +1,79 @@
1DESCRIPTION = "This package includes some useful diagnostics tools for \
2IPv6 networks, including ndisc6, rdisc6, tcptraceroute6 and traceroute6."
3SECTION = "net"
4HOMEPAGE = "http://www.remlab.net/ndisc6/"
5LICENSE = "GPL-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8PV = "1.0.4+git${SRCPV}"
9SRCREV = "4c794b5512d23c649def1f94a684225dcbb6ac3e"
10SRC_URI = "git://git.remlab.net/git/ndisc6.git;protocol=http \
11 file://0001-replace-VLAIS-with-malloc-free-pair.patch \
12 file://0002-Do-not-undef-_GNU_SOURCE.patch \
13 file://0001-autogen-Do-not-symlink-gettext.h-from-build-host.patch \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit autotools gettext
19
20EXTRA_OECONF += "PERL=${USRBINPATH}/perl"
21
22LDFLAGS += "-fuse-ld=gold"
23TOOLCHAIN = "gcc"
24
25do_configure_prepend() {
26 cp ${STAGING_DATADIR_NATIVE}/gettext/gettext.h ${S}/include
27 ${S}/autogen.sh
28}
29
30do_install_append () {
31 rm -rf ${D}${localstatedir}
32 # Enable SUID bit for applications that need it
33 chmod 4555 ${D}${bindir}/rltraceroute6
34 chmod 4555 ${D}${bindir}/ndisc6
35 chmod 4555 ${D}${bindir}/rdisc6
36}
37ALLOW_EMPTY_${PN} = "1"
38
39# Split into seperate packages since we normal don't want them all
40# The main package is left empty and therefore not created.
41PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \
42 ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \
43 ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc"
44FILES_${PN} = ""
45FILES_${PN}-ndisc6 = "${bindir}/ndisc6"
46FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6"
47FILES_${PN}-rdisc6 = "${bindir}/rdisc6"
48FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6"
49FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6"
50FILES_${PN}-tracert6 = "${bindir}/tracert6"
51FILES_${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd"
52FILES_${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name"
53
54DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \
55Performs IPv6 neighbor discovery in userland. Replaces arping from the \
56IPv4 world."
57DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \
58Queries IPv6 routers on the network for advertised prefixes. Can be used \
59to detect rogue IPv6 routers, monitor legitimate IPv6 routers."
60DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \
61sessions between the local system and a remote echo server in either IPv6 \
62or IPv4."
63
64DESCRITPION_${PN}-rdnssd = "Daemon to autoconfigure the list of DNS \
65servers through slateless IPv6 autoconfiguration."
66
67# The tcptraceroute6 and tracert6 commands depend on rltraceroute6 to
68# perform the actual trace operation.
69RDEPENDS_${PN}-tcptraceroute6 = "${PN}-rltraceroute6"
70RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6"
71RDEPENDS_${PN}-misc += "perl"
72
73do_install_append () {
74 rm -rf ${D}${localstatedir}
75 # Enable SUID bit for applications that need it
76 chmod 4555 ${D}${bindir}/rltraceroute6
77 chmod 4555 ${D}${bindir}/ndisc6
78 chmod 4555 ${D}${bindir}/rdisc6
79}