summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb')
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb
new file mode 100644
index 000000000..0b5c9e467
--- /dev/null
+++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.3.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "This package includes some useful diagnostics tools for \
2IPv6 networks, including ndisc6, rdisc6, tcptraceroute6 and traceroute6."
3SECTION = "net"
4HOMEPAGE = "http://www.remlab.net/ndisc6/"
5LICENSE = "GPL-2.0"
6
7# The tcptraceroute6 and tracert6 commands depend on rltraceroute6 to
8# perform the actual trace operation.
9RDEPENDS_${PN}-tcptraceroute6 = "${PN}-rltraceroute6"
10RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6"
11RDEPENDS_${PN}-misc += "perl"
12
13SRC_URI = "http://www.remlab.net/files/ndisc6/ndisc6-${PV}.tar.bz2 \
14"
15SRC_URI[md5sum] = "21afdaa3a5a5c1ce50eb7f2b7d795989"
16SRC_URI[sha256sum] = "0f41d6caf5f2edc1a12924956ae8b1d372e3b426bd7b11eed7d38bc974eec821"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
19
20inherit autotools gettext
21
22ALLOW_EMPTY_${PN} = "1"
23
24# Split into seperate packages since we normal don't want them all
25# The main package is left empty and therefore not created.
26PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \
27 ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \
28 ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc"
29FILES_${PN} = ""
30FILES_${PN}-ndisc6 = "${bindir}/ndisc6"
31FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6"
32FILES_${PN}-rdisc6 = "${bindir}/rdisc6"
33FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6"
34FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6"
35FILES_${PN}-tracert6 = "${bindir}/tracert6"
36FILES_${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd"
37FILES_${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name"
38
39DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \
40Performs IPv6 neighbor discovery in userland. Replaces arping from the \
41IPv4 world."
42DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \
43Queries IPv6 routers on the network for advertised prefixes. Can be used \
44to detect rogue IPv6 routers, monitor legitimate IPv6 routers."
45DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \
46sessions between the local system and a remote echo server in either IPv6 \
47or IPv4."
48
49DESCRITPION_${PN}-rdnssd = "Daemon to autoconfigure the list of DNS \
50servers through slateless IPv6 autoconfiguration."
51
52do_install_append () {
53 rm -rf ${D}${localstatedir}
54 # Enable SUID bit for applications that need it
55 chmod 4555 ${D}${bindir}/rltraceroute6
56 chmod 4555 ${D}${bindir}/ndisc6
57 chmod 4555 ${D}${bindir}/rdisc6
58}