summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libmemcached/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/libmemcached/files')
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch38
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch28
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch30
3 files changed, 96 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch b/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch
new file mode 100644
index 000000000..26b5e250c
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch
@@ -0,0 +1,38 @@
1From ed4422979b221c8613ca02eb5c57cb80009366d1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:13:24 -0700
4Subject: [PATCH 1/2] Fix comparison types
5
6Fixes
7error: comparison between pointer and integer ('char *' and 'int')
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 clients/memflush.cc | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/clients/memflush.cc b/clients/memflush.cc
15index 8bd0dbf..71545ea 100644
16--- a/clients/memflush.cc
17+++ b/clients/memflush.cc
18@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
19 {
20 options_parse(argc, argv);
21
22- if (opt_servers == false)
23+ if (opt_servers == NULL)
24 {
25 char *temp;
26
27@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
28 opt_servers= strdup(temp);
29 }
30
31- if (opt_servers == false)
32+ if (opt_servers == NULL)
33 {
34 std::cerr << "No Servers provided" << std::endl;
35 exit(EXIT_FAILURE);
36--
372.12.0
38
diff --git a/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch b/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch
new file mode 100644
index 000000000..06febc5b1
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch
@@ -0,0 +1,28 @@
1From fa0fe001a5373c1ef9ff2175555b14fc07399e1b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:01:44 -0700
4Subject: [PATCH] configure.ac: Do not configure build-aux
5
6Fixes
7configure: error: cannot find install-sh, install.sh, or shtool
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 configure.ac | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/configure.ac b/configure.ac
15index 17b7351..0263112 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -17,7 +17,6 @@ AC_INIT([libmemcached],VERSION_NUMBER,[http://libmemcached.org/])
19 AC_PROG_CC([cc gcc clang])
20 AC_PROG_CXX([c++ g++ clang++])
21
22-AC_CONFIG_AUX_DIR([build-aux])
23 AC_CONFIG_MACRO_DIR([m4])
24
25 AC_CANONICAL_HOST
26--
272.12.0
28
diff --git a/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch b/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch
new file mode 100644
index 000000000..e1e1be8c6
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch
@@ -0,0 +1,30 @@
1From e95609e4ae40a794ed198924505fd22d7d86a124 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:16:14 -0700
4Subject: [PATCH 2/2] POSIX_SPAWN_USEVFORK is not linux specific but glibc
5 specific
6
7Fixes
8cmdline.cc:206:12: error: use of undeclared identifier 'POSIX_SPAWN_USEVFORK'
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libtest/cmdline.cc | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libtest/cmdline.cc b/libtest/cmdline.cc
16index 29a22de..34f0a89 100644
17--- a/libtest/cmdline.cc
18+++ b/libtest/cmdline.cc
19@@ -201,7 +201,7 @@ Application::error_t Application::run(const char *args[])
20
21 fatal_assert(posix_spawnattr_setsigmask(&spawnattr, &mask) == 0);
22
23-#if defined(POSIX_SPAWN_USEVFORK) || defined(__linux__)
24+#if defined(POSIX_SPAWN_USEVFORK) || defined(__GLIBC__)
25 // Use USEVFORK on linux
26 flags |= POSIX_SPAWN_USEVFORK;
27 #endif
28--
292.12.0
30