summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb')
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb b/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
new file mode 100644
index 000000000..3e045bb27
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Crontab entry to provide weekly updates of the GeoIP free databases."
2DESCRIPTION = "update databases for GeoIP"
3
4HOMEPAGE = "http://dev.maxmind.com/geoip/"
5SECTION = "net"
6
7DEPENDS = "zlib curl"
8
9SRC_URI = "https://github.com/maxmind/geoipupdate/releases/download/v2.4.0/geoipupdate-2.4.0.tar.gz \
10 file://GeoIP.conf \
11 file://geoipupdate.cron \
12 "
13SRC_URI[md5sum] = "02f9712fb80e8e979d3d54cda7f7704f"
14SRC_URI[sha256sum] = "8b4e88ce8d84e9c75bc681704d19ec5c63c54f01e945f7669f97fb0df7e13952"
15
16LICENSE = "GPLv2"
17
18LIC_FILES_CHKSUM = "\
19file://ChangeLog.md;md5=334337b6ecbb65093bae66b3ae21c8c2 \
20"
21FILES_${PN} = "/usr/share/GeoIP \
22 /etc/GeoIP.conf \
23 /etc/cron.d/geoipupdate.cron \
24 /usr/bin/geoipupdate \
25"
26inherit autotools
27
28do_install_append() {
29 install -d ${D}/${sysconfdir}
30 install -d ${D}/${sysconfdir}/cron.d
31 install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/
32 install ${WORKDIR}/geoipupdate.cron ${D}/${sysconfdir}/cron.d/
33}