summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb')
-rw-r--r--meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb b/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb
new file mode 100644
index 000000000..6fb621a1f
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch \
13 "
14
15SRC_URI[md5sum] = "f2e6eaa92861252af0b564f0100f1859"
16SRC_URI[sha256sum] = "d6b4188ed01d8555c78b04b5e31532d5990ca98bf063230f3e949ee8a7338d58"
17
18inherit module
19
20EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
21
22do_install () {
23 oe_runmake install DESTDIR="${D}"
24}