summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb')
-rw-r--r--meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb b/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb
new file mode 100644
index 000000000..d6750ab2f
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch"
13
14SRC_URI[md5sum] = "ae8d5030760b2820a4b3e250447890a0"
15SRC_URI[sha256sum] = "86dd6cc0fdc8123056a3bb67a634cd7ba62a7b05b23caab9995cce7730891da8"
16
17inherit module
18
19EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
20
21do_install () {
22 oe_runmake install DESTDIR="${D}"
23}