summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
new file mode 100644
index 000000000..0e3f952c9
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
11SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
12 git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
13 file://0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
14 "
15# v9.5.0
16SRCREV_drbd-utils = "ee126652638328b55dc6bff47d07d6161ab768db"
17SRCREV_drbd-headers = "b47cc11bcabe1a65c40ad23f71dcaf2da6419630"
18
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
22
23SYSTEMD_SERVICE_${PN} = "drbd.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26inherit autotools-brokensep systemd
27
28EXTRA_OECONF = " \
29 --with-initdir=/etc/init.d \
30 --without-pacemaker \
31 --without-rgmanager \
32 --without-bashcompletion \
33 --with-distro debian \
34 --with-initscripttype=both \
35 --with-systemdunitdir=${systemd_unitdir}/system \
36 --without-manual\
37 "
38
39do_install_append() {
40 # don't install empty /var/lock to avoid conflict with base-files
41 rm -rf ${D}${localstatedir}/lock
42}
43
44RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
45
46# The drbd items are explicitly put under /lib when installed.
47#
48FILES_${PN} += "/run"
49FILES_${PN} += "${nonarch_base_libdir}/drbd \
50 ${nonarch_libdir}/drbd \
51 ${nonarch_libdir}/tmpfiles.d"
52FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"