summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dovecot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dovecot')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch91
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/building-rquota_xdr.c-depend-on-rquota.h.patch28
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb45
3 files changed, 164 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
new file mode 100644
index 000000000..6f5c279be
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
@@ -0,0 +1,91 @@
1From 483f120603ada8db680085e3f462396da937e036 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 8 Jan 2014 09:30:36 +0100
4Subject: [PATCH] configure.ac: convert AC_TRY_RUN to AC_TRY_LINK statements
5
6This is not completely safe, but it's the least invasive fix.
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9Upstream-status: Inappropriate
10---
11 configure.ac | 23 +++++++----------------
12 1 file changed, 7 insertions(+), 16 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 95984bb..dff1f87 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -499,13 +499,10 @@ have_ioloop=no
19
20 if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
21 AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
22- AC_TRY_RUN([
23+ AC_TRY_LINK([
24 #include <sys/epoll.h>
25-
26- int main()
27- {
28- return epoll_create(5) < 1;
29- }
30+ ], [
31+ epoll_create(5) < 1;
32 ], [
33 i_cv_epoll_works=yes
34 ], [
35@@ -551,15 +548,13 @@ have_notify=none
36 if test "$notify" = "" || test "$notify" = "inotify" ; then
37 dnl * inotify?
38 AC_CACHE_CHECK([whether we can use inotify],i_cv_inotify_works,[
39- AC_TRY_RUN([
40+ AC_TRY_LINK([
41 #define _GNU_SOURCE
42 #include <sys/ioctl.h>
43 #include <fcntl.h>
44 #include <sys/inotify.h>
45 #include <stdio.h>
46-
47- int main()
48- {
49+ ], [
50 int wd, fd;
51 char * fn = "/tmp";
52
53@@ -581,8 +576,6 @@ if test "$notify" = "" || test "$notify" = "inotify" ; then
54 inotify_rm_watch (fd, wd);
55
56 close (fd);
57- return 0;
58- }
59 ], [
60 i_cv_inotify_works=yes
61 ], [
62@@ -670,7 +663,7 @@ fi
63 dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
64 dnl * It may also be broken in AIX.
65 AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
66- AC_TRY_RUN([
67+ AC_TRY_LINK([
68 #define _XOPEN_SOURCE 600
69 #include <stdio.h>
70 #include <stdlib.h>
71@@ -679,7 +672,7 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
72 #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
73 possibly broken posix_fallocate
74 #endif
75- int main() {
76+ ], [
77 int fd = creat("conftest.temp", 0600);
78 int ret;
79 if (fd == -1) {
80@@ -688,8 +681,6 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
81 }
82 ret = posix_fallocate(fd, 1024, 1024) < 0 ? 1 : 0;
83 unlink("conftest.temp");
84- return ret;
85- }
86 ], [
87 i_cv_posix_fallocate_works=yes
88 ], [
89--
901.8.4.2
91
diff --git a/meta-networking/recipes-support/dovecot/dovecot/building-rquota_xdr.c-depend-on-rquota.h.patch b/meta-networking/recipes-support/dovecot/dovecot/building-rquota_xdr.c-depend-on-rquota.h.patch
new file mode 100644
index 000000000..11d9d8c0d
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot/building-rquota_xdr.c-depend-on-rquota.h.patch
@@ -0,0 +1,28 @@
1[PATCH] building rquota_xdr.c depends on rquota.h
2
3Upstream-status: Pending
4
5rquota.h is generated automatically, and building rquota_xdr.c
6needs rquota.h, so add the dependency on rquota.h for rquota_xdr.c
7
8Signed-off-by: rongqing li <rli2@yow-blade4.wrs.com>
9---
10 src/plugins/quota/Makefile.am | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/plugins/quota/Makefile.am b/src/plugins/quota/Makefile.am
14index 8a6988d..3626d79 100644
15--- a/src/plugins/quota/Makefile.am
16+++ b/src/plugins/quota/Makefile.am
17@@ -70,7 +70,7 @@ RQUOTA_XDR = rquota_xdr.c
18 RQUOTA_XDR_LO = rquota_xdr.lo
19 #RQUOTA_X = /usr/include/rpcsvc/rquota.x
20 RQUOTA_X = $(srcdir)/rquota.x
21-rquota_xdr.c: Makefile $(RQUOTA_X)
22+rquota_xdr.c: Makefile $(RQUOTA_X) rquota.h
23 if [ "$(top_srcdir)" != "$(top_builddir)" ]; then \
24 cp $(RQUOTA_X) $(top_builddir)/src/plugins/quota/; \
25 fi; \
26--
271.8.2.1
28
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
new file mode 100644
index 000000000..f733a7832
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
2DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
3
4LICENSE = "LGPLv2.1 & MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b"
6
7SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \
8 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
9 file://building-rquota_xdr.c-depend-on-rquota.h.patch \
10 "
11SRC_URI[md5sum] = "037e9c9e07d9dbff54dcff09f280fc8c"
12SRC_URI[sha256sum] = "75592483d40dc4f76cc3b41af40caa4be80478946a699d46846d5d03e4d2e09b"
13
14DEPENDS = "openssl xz zlib bzip2 libcap"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= " \
19 ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
20 ${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
21 "
22
23PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
24PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
25
26# From native build in armv7a-hf/eglibc
27CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
28 i_cv_gmtime_max_time_t=32 \
29 i_cv_signed_time_t=yes \
30 i_cv_mmap_plays_with_write=yes \
31 i_cv_fd_passing=yes \
32 i_cv_c99_vsnprintf=yes \
33 lib_cv___va_copy=yes \
34 lib_cv_va_copy=yes \
35 lib_cv_va_val_copy=yes \
36 "
37
38# hardcode epoll() to avoid running unsafe tests
39# BSD needs kqueue and uclibc poll()
40EXTRA_OECONF = " --with-ioloop=epoll"
41
42FILES_${PN}-staticdev += "${libdir}/dovecot/*/*.a"
43FILES_${PN}-dev += "${libdir}/dovecot/*.so"
44FILES_${PN}-dbg += "${libdir}/dovecot/*/.debug"
45