summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb
new file mode 100644
index 000000000..b2a3de394
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb
@@ -0,0 +1,68 @@
1SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
2DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
3SECTION = "mail"
4LICENSE = "LGPLv2.1 & MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b"
6
7SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \
8 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
9 file://dovecot.service \
10 file://dovecot.socket"
11
12SRC_URI[md5sum] = "ff95486a5c43025a2c3f5a712e7962b9"
13SRC_URI[sha256sum] = "d939ea99126eb8a8c6955390b422b6e27ec0fa43a3b59b2b3218cb5ad67139a6"
14
15DEPENDS = "openssl xz zlib bzip2 libcap icu"
16
17DEPENDS_append_libc-musl = " libtirpc"
18CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
19LDFLAGS_append_libc-musl = " -ltirpc"
20
21inherit autotools pkgconfig systemd useradd
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam', d)}"
24
25PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
26PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
27PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
28
29# From native build in armv7a-hf/eglibc
30CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
31 i_cv_gmtime_max_time_t=32 \
32 i_cv_signed_time_t=yes \
33 i_cv_mmap_plays_with_write=yes \
34 i_cv_fd_passing=yes \
35 i_cv_c99_vsnprintf=yes \
36 lib_cv___va_copy=yes \
37 lib_cv_va_copy=yes \
38 lib_cv_va_val_copy=yes \
39 "
40
41# hardcode epoll() to avoid running unsafe tests
42# BSD needs kqueue and uclibc poll()
43EXTRA_OECONF = " --with-ioloop=epoll \
44 --with-systemdsystemunitdir=${systemd_unitdir}/system"
45
46SYSTEMD_PACKAGES = "${PN}"
47SYSTEMD_SERVICE_${PN} = "dovecot.service dovecot.socket"
48SYSTEMD_AUTO_ENABLE = "disable"
49
50do_install_append () {
51 install -d 755 ${D}/etc/dovecot
52 touch 644 ${D}/etc/dovecot/dovecot.conf
53 install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system
54 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service
55 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service
56}
57
58USERADD_PACKAGES = "${PN}"
59USERADD_PARAM_${PN} = "-r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovecot dovecot; \
60 -r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovenull dovenull"
61GROUPADD_PARAM_${PN} = "-f -r dovecot;-f -r dovenull"
62
63FILES_${PN} += "${libdir}/dovecot/*plugin.so \
64 ${libdir}/dovecot/libfs_compress.so \
65 ${libdir}/dovecot/libssl_iostream_openssl.so"
66FILES_${PN}-staticdev += "${libdir}/dovecot/*/*.a"
67FILES_${PN}-dev += "${libdir}/dovecot/libdovecot*.so"
68FILES_${PN}-dbg += "${libdir}/dovecot/*/.debug"